PAT (Advanced Level) Practice 1019 General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits a~i~ as the sum of (a~i~b^i^) for i from 0 to k. Here, as usual, 0 <= a~i~ < b for all i and a~k~ is non-zero. Then N is palindromic if and only if a~i~ = a~k-i~ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 10^9^ is the decimal number and 2 <= b <= 10^9^ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "a~k~ a~k-1~ ... a~0~". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题意:

输入一个十进制得数,将它转换成K进制,并判断其K进制数是否为回文数,如果是就打印Yes,不是就打印No

C++:

#include<cstdio>
#include<cstring>   // strrev为字符串的倒序 

bool isPalindromic(int a[],int num){  
	for(int i = 0;i <= num/2;i++){
		if(a[i] != a[num-i-1])
			return false;
	}	
	return true;
}

int main(){
	int N,k;
	int a[1000];
	scanf("%d%d",&N,&k);   //十进制 N 转化成 k进制数后判断是否是回文
	
	//修改几进制 
	int t = N;  
	int count=0;  //为位数,接下来打印循环的次数 
	
	do{
		a[count++] = t % k;    // 将正整数的最低位保存到数组a中
        t /= k;            // 将正整数的次低位变为最低位      
	}while(t) ; //这样的话 t为 0 也会被执行一次 
	 
	if(isPalindromic(a,count))
		printf("Yes\n");		
	else
		printf("No\n");
		
	for(int i = count-1;i >= 0;i--){
		printf("%d",a[i]);
		if(i) 	
			printf(" "); 
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值