HDU-6015-Skip the Class(STL:map)

Skip the Class

Problem Description
Finally term begins. luras loves school so much as she could skip the class happily again.(wtf?)

Luras will take n lessons in sequence(in another word, to have a chance to skip xDDDD).

For every lesson, it has its own type and value to skip.

But the only thing to note here is that luras can't skip the same type lesson more than twice.

Which means if she have escaped the class type twice, she has to take all other lessons of this type.

Now please answer the highest value luras can earn if she choose in the best way.

Input
The first line is an integer T which indicates the case number.

And as for each case, the first line is an integer n which indicates the number of lessons luras will take in sequence.

Then there are n lines, for each line, there is a string consists of letters from 'a' to 'z' which is within the length of 10,
and there is also an integer which is the value of this lesson.

The string indicates the lesson type and the same string stands for the same lesson type.

It is guaranteed that——

T is about 1000

For 100% cases, 1 <= n <= 100,1 <= |s| <= 10, 1 <= v <= 1000

Output
As for each case, you need to output a single line.
there should be 1 integer in the line which represents the highest value luras can earn if she choose in the best way.

Sample Input
  
  
2 5 english 1 english 2 english 3 math 10 cook 100 2 a 1 a 2

Sample Output
  
  
115 3

Source


#include<bits/stdc++.h>
using namespace std;

struct node {
	char s[20];
	int val;
} ca[105];

bool cmp(node a,node b) {
	return a.val>b.val;
}
int main() {
	int t,n;
	cin>>t;
	map<string,int>mp;
	while(t--) {
		cin>>n;
		mp.clear();//清空!!
		for(int i=0; i<n; i++) {
			cin>>ca[i].s>>ca[i].val;
		}
		sort(ca,ca+n,cmp);
		int sum=0;
		for(int i=0; i<n; i++) {
			if(mp[ca[i].s]==2)
				continue;
			else {
				mp[ca[i].s]++;
				sum+=ca[i].val;
			}
		}
		printf("%d\n",sum);
	}
}

STL学习,map应用,贪心算法

题意大概是:逃课最多两次,求逃课的最大价值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值