POJ-3254-Corn Fields【状压dp】

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17755 Accepted: 9345

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<cmath>
#include<string.h>
using namespace std;
int ans,n,m,dp[13][1<<13],map[13],st[1<<13];
int M=1e8;
int judge1(int x)//如果相邻返回1,否则返回0.
{
    if(x&(x<<1))
        return 1;
    return 0;
}
int judge2(int i,int x)//如果和贫瘠土地冲突返回1,不冲突否则返回0.
{
    if(map[i]&x)
        return 1;
    return 0;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(map,0,sizeof(map));
         memset(st,0,sizeof(st));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                int x;
                scanf("%d",&x);
                if(x==0)
                    map[i]+=1<<(j-1);//让每一行贫瘠的变成1,肥沃的为0。
            }
        }
        int tot=0;
        for(int i=0; i<(1<<m); i++) //所有行都一样,排除相邻情况。
        {
            if(!judge1(i))
            {
                tot++;
                st[tot]=i;
            }
        }
        for(int i=1; i<=tot; i++) //先检查第一行状态冲突情况。
        {
            if(!judge2(1,st[i]))
                dp[1][i]=1;//第一行第i种状态
        }
        for(int i=2; i<=n; i++)
        {
            for(int j=1; j<=tot; j++)
            {
                if(judge2(i,st[j])) continue;
                for(int k=1; k<=tot; k++)
                {
                    if(judge2(i-1,st[k])) continue;//剪枝
                    if((st[j]&st[k])==0)
                    {
                        dp[i][j]+=dp[i-1][k];
                        dp[i][j]%=M;
                    }
                }
            }
        }

        for (int i=1; i<=tot; i++)
        {
            ans+=dp[n][i];
            ans%=M;
        }
        printf("%d\n",ans);
    }
}

【题目大意】一个矩阵里有很多格子,每个格子有两种状态,可以放牧和不可以放牧,可以放牧用1表示,否则用0表示,在这块牧场放牛,要求两个相邻的方格不能同时放牛,即牛与牛不能相邻。问有多少种放牛方案(一头牛都不放也是一种方案)

【解析】根据题意,把每一行的状态用二进制的数表示,1代表不在这块放牛,0表示在这一块放牛。首先很容易看到,每一行的状态要符合牧场的硬件条件,即牛必须放在能放牧的方格上。这样就能排除一些状态。另外,牛与牛之间不能相邻,这样就要求每一行中不能存在两个相邻的1,这样也能排除很多状态。然后就是根据上一行的状态转移到当前行的状态的问题了。必须符合不能有两个1在同一列(两只牛也不能竖着相邻)的条件。这样也能去掉一些状态。然后,上一行的所有符合条件的状态的总的方案数就是当前行该状态的方案数。

【状态表示】dp[state][i]:在状态为state时,到第i行符合条件的可以放牛的方案数

【状态转移方程】dp[state][i] =Sigma dp[state'][i-1] (state'为符合条件的所有状态)

【DP边界条件】首行放牛的方案数dp[state][1] =1(state符合条件) OR 0 (state不符合条件)



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值