哈理工OJ-2326-Blind Father

HRBUST - 2326
Mr. Leng, who is the predominately inheritor of buried-love family (One of the most vogue families during your primary school maybe, anyway, this is unimportant), has such cool, cooler and coolest temperament. But, only a good ACMer can be the real leader, in other words, be admitted as a successor.
One day, a problem come to Mr. Leng 's father about carpentry. There are N pieces of planks upright the ground in one line. Each one width 1 and height uncertain. His father wants to cut some of them and then get a rectangle. How the biggest rectangle does him can make? It too difficult to his father to solve the problem, but it is really easy for Mr. Leng. So do you. Please surmount the problem as soon as you can.
Ps: You can’t move or change the posture or position of any planks.
Input
There are multiple cases. In each cases, the first line only contains an integer N,
means the number of the planks. And the second line contains N numbers, means the height of N planks one by one.
1<=N<=10000
Output
Please output the biggest rectangle that Mr. Leng 's father can get.
Sample Input
3
10 6 10
Sample Output
18
Hint
样例图形
这里写图片描述

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;

    while(~scanf("%d",&n))
    {int a[n];
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int ans=-1;
        for(int i=0;i<n;i++)
        {
            int L=i;
            int R=i;
            for(int j=i;j>=0;j--)
            {
                if(a[j]>=a[i])
                    L=j;
                else
                    break;
            }
            for(int j=i;j<n;j++)
            {
                if(a[j]>=a[i])
                    R=j;
                else
                    break;
            }
            ans=max(ans,(R-L+1)*a[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值