数据结构实验之查找七:线性之哈希表

数据结构实验之查找七:线性之哈希表

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

根据给定的一系列整数关键字和素数p,用除留余数法定义hash函数H(Key)=Key%p,将关键字映射到长度为p的哈希表中,用线性探测法解决冲突。重复关键字放在hash表中的同一位置。

Input

连续输入多组数据,每组输入数据第一行为两个正整数N(N <= 1000)和p(p >= N的最小素数),N是关键字总数,p是hash表长度,第2行给出N个正整数关键字,数字间以空格间隔。

Output

输出每个关键字在hash表中的位置,以空格间隔。注意最后一个数字后面不要有空格。

Example Input
5 5
21 21 21 21 21
4 5
24 15 61 88
4 5
24 39 61 15
5 5
24 39 61 15 39
Example Output
1 1 1 1 1
4 0 1 3
4 0 1 2
4 0 1 2 0
Hint
 
Author
#include<iostream>
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,p,i;
    int ha[10000],a[10000];
    while(cin>>n>>p)
    {
        memset(ha,0,sizeof(ha));
        for(i=0;i<n;i++)
        {
            cin>>a[i];
            int t=a[i]%p;
            if(!ha[t])
            {
                ha[t]=a[i];
                if(i==n-1)
                    cout<<t<<endl;
                else
                    cout<<t<<" ";
            }
            else if(a[i]==ha[t])
            {
                if(i==n-1)
                    cout<<t<<endl;
                else
                cout<<t<<" ";
            }

            else
            {
                int d=1,flag=0;
                while(ha[(t+d)%p])//寻找没有占用的位置
                {
                    if(a[i]==ha[(t+d)%p])//元素已经存储过
                    {
                        flag=1;
                        if(i==n-1)
                            cout<<(t+d)%p<<endl;
                        else
                            cout<<(t+d)%p<<" ";
                            break;

                    }
                        d++;
                }
                ha[(t+d)%p]=a[i];

                if(flag==0)
                {
                    if(i==n-1)
                    cout<<(t+d)%p<<endl;
                else
                cout<<(t+d)%p<<" ";
                }
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值