1、题目
请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。
所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。
输入格式:
输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。
输出格式:
在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。
随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。
输入样例:
This is a test.
The word "this" is the word with the highest frequency.
Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee. But this_8 is different than this, and this, and this...#
this line should be ignored.
输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)
23
5:this
4:is
2、主要思路
1、从输入文本中扣出合法单词;2、将不同单词存出入map<string,int>中,并记录相同单词的字数。
注意点
题目中:所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。
意思是:当比较两个单词是否相同时,只比较前15个字符,只要前15个字符相同则相同。
3、我的代码
#include<iostream>
#include<map>
#include<string>
using namespace std;
map<string,int> words;
int wordNum=0;
void pushMap(string &word,int &connectNum)
{
if(words[word]==0)
{
wordNum++;
words[word]=1;
}
else
words[word]++;
word="";
connectNum=0;
}
int main()
{
string str,word;
int connectNum=0,cutNum=0;
while(cin>>str)
{
for(int i=0;i<str.length();i++)
{
if(str[i]=='#')
{
//要将最后一个word存入map
if(i==str.length()-1&&connectNum>0)
{
pushMap(word,connectNum);
}
printf("%d\n",wordNum);
int printNum=wordNum/10;
for(int j=0;j<printNum;j++)
{
int maxNum=0;
string maxStr;
for(map<string,int>::iterator it=words.begin();it!=words.end();it++)
{
if(it->second>maxNum)
{
maxNum=it->second;
maxStr=it->first;
}
}
cout<<maxNum<<':'<<maxStr<<endl;
words.erase(maxStr);
}
return 0;
}
if(connectNum==15)
{
pushMap(word,connectNum);
break;
}
if(str[i]>='A'&&str[i]<='Z')
{
word+=str[i]+32;
connectNum++;
}
else if(str[i]>='a'&&str[i]<='z'||str[i]>='0'&&str[i]<='9'||str[i]=='_')
{
word+=str[i];
connectNum++;
}
else
{
if(connectNum>0)
{
pushMap(word,connectNum);
continue;
}
}
if(i==str.length()-1&&connectNum>0)
{
pushMap(word,connectNum);
}
}
}
return 0;
}