HDU Walk

Description

I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

Input

The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

Output

For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

Sample Input

    
    
2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

Sample Output

  
  
0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037

解析

这道题显然是一道概率DP,只是转移方程略难写。每一次求一个点没到达的概率,都要跑一次DP。

求dian的概率时 dp[i][j]表示在不路过dian的情况下,走j步恰走到i的概率。特别的,当i==dian表示走j步恰好第一次走到dian的概率。转移方程  f [ i ] [ j ] += f [ i-1 ] [ p ] / 到j的概率 ( p可以到j且p不是dian)

所以输出的结果就是

double ans=1;

for(int i=0;i<=D;i++) ans-=dp[dian][i];

还有个坑点,就是可能输出-0所以输出的时候记得取绝对值。

#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>

using namespace std;

double dp[60][10010];//dp[i][j]表示走完j步恰停在i点的概率
//int dp[60];
int N,M,D;
vector<int> Chain[60];

void readdata()
{
	for(int i=1;i<=N;i++) Chain[i].clear();

	scanf("%d%d%d",&N,&M,&D);
	for(int i=1;i<=M;i++)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		Chain[a].push_back(b);
		Chain[b].push_back(a);
	}
}

void DP()
{
	memset(dp,0,sizeof(dp));
	//for(int i=1;i<=N;i++) dp[i][0]=1.0/N;

	for(int dian=1;dian<=N;dian++)
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=N;i++) dp[i][0]=1.0/N;
		//f[j][i]表示走i步到j而不路过dian的概率 j==dian的情况下是走i步第一次到达dian的概率
		for(int i=0;i<D;i++)//走i步
			for(int j=1;j<=N;j++)//枚举第j个点
			{
				if(j==dian) continue;//根据定义不能路过dian所以不能在j==dian的情况下向其它点转移
				for(vector<int>::iterator k=Chain[j].begin(); k!=Chain[j].end(); k++)
					dp[*k][i+1]+=(dp[j][i]/Chain[j].size());
			}
		double ans=1;
		for(int i=0;i<=D;i++) ans-=dp[dian][i];
		printf("%.10f\n",fabs(ans));
	}
}

int main()
{
	freopen("E.in","r",stdin);
	freopen("E.out","w",stdout);

	int T;
	scanf("%d",&T);
	for(int i=1;i<=T;i++)
	{
		readdata();
		DP();
	}
	//while(1);
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值