HDU 4165 Pills

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Status

Description

Aunt Lizzie takes half a pill of a certain medicine every day. She starts with a bottle that contains N pills.

On the first day, she removes a random pill, breaks it in two halves, takes one half and puts the other half back into the bottle.

On subsequent days, she removes a random piece (which can be either a whole pill or half a pill) from the bottle. If it is half a pill, she takes it. If it is a whole pill, she takes one half and puts the other half back into the bottle.

In how many ways can she empty the bottle? We represent the sequence of pills removed from the bottle in the course of 2N days as a string, where the i-th character is W if a whole pill was chosen on the i-th day, and H if a half pill was chosen (0 <= i < 2N). How many different valid strings are there that empty the bottle?
 

Input

The input will contain data for at most 1000 problem instances. For each problem instance there will be one line of input: a positive integer N <= 30, the number of pills initially in the bottle. End of input will be indicated by 0.
 

Output

For each problem instance, the output will be a single number, displayed at the beginning of a new line. It will be the number of different ways the bottle can be emptied.
 

Sample Input

    
    
6 1 4 2 3 30 0
 

Sample Output

    
    
132 1 14 2 5 3814986502092304
 

Source

The 2011 Rocky Mountain Regional Contest

解析

动规/记忆化搜索/卡特兰数

http://www.cnblogs.com/Su-Blog/archive/2012/08/22/2651504.html

博客讲的非常好

这里就直接给代码了

#include<cstdio>

using namespace std;

int N;
typedef long long LL;
LL catalan[35];
int main()
{
	catalan[1]=1;
	for(int i=2;i<=30;i++)
		catalan[i]=2*(2*i-1)*catalan[i-1]/(i+1);
	while(scanf("%d",&N)==1)
	{
		if(N==0) break;
		printf("%I64d\n",catalan[N]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值