hdu 3371 Connect the Cities Prim + Kruskal两种算法分别AC 水过~~~~

50 篇文章 0 订阅
17 篇文章 0 订阅

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11727    Accepted Submission(s): 3278


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
  
  
1
 

Author
dandelion
 
转载请申明博客原地址: http://blog.csdn.net/lionel_d

FUUUUUUUUUUUUUUUUUUUCK,,我又忘了判断重边!!!!
好吧,是我太笨了!
首先这道题很简单,我们只要两重循环把相连的城市之间的距离设置为0就可以了,
Prim算法400MS+,而Kruskal算法700MS+,并且我还做了并查集优化。

Prim算法代码:
#include <stdio.h>
#include <string.h>
#define MAX 550
#define INF 100000000

int graph[MAX][MAX] ;

int prim(int n)
{
	int sum = 0 ,lowCost[MAX] ;
	bool visited[MAX] ;
	memset(visited,false,sizeof(visited)) ;
	for(int i = 1 ; i <= n ; ++i)
	{
		lowCost[i] = graph[1][i] ;
	}
	visited[1] = true ;
	for(int i = 1 ; i < n ; ++i)
	{
		int min = INF , index = -1 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && min>lowCost[j])
			{
				min = lowCost[j] ;
				index = j ;
			}
		}
		if(index == -1)
		{
			if(i < n)
			{
				return INF ;
			}
			break ;
		}
		sum += lowCost[index] ;
		visited[index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && lowCost[j]>graph[index][j])
			{
				lowCost[j] = graph[index][j] ;
			}
		}
	}
	return sum ;
}
int main()
{
	int t ;
	scanf("%d",&t);
	while(t--)
	{
		int n , m , k;
		scanf("%d%d%d",&n,&m,&k) ;
		for(int i = 1 ; i <= n ; ++i)
		{
			graph[i][i] = 0 ;
			for(int j = 1 ; j < i ; ++j)
			{
				graph[i][j] = graph[j][i] = INF ;
			}
		}
		for(int i = 0 ; i < m ; ++i)
		{
			int x, y ,w ;
			scanf("%d%d%d",&x,&y,&w) ;
			if(w<graph[x][y])
			{
				graph[x][y] = graph[y][x] = w; 
			}
		}
		int p[MAX] ;
		for(int i = 0 ; i < k ; ++i)
		{
			int t ;
			scanf("%d",&t);
			for(int j = 0 ; j < t ; ++j)
			{
				scanf("%d",&p[j]);
			}
			for(int j = 0 ; j < t ; ++j)
			{
				for(int r = 0 ; r < j ; ++r)
				{
					graph[p[j]][p[r]] = graph[p[r]][p[j]] = 0 ;
				}
			}
		}
		int sum = prim(n) ;
		if(sum >= INF)
		{
			puts("-1") ;
		}
		else
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}

Kruskal算法代码:
#include <cstdio>
#include <algorithm>
#include <cstring>
#define MAX 550
#define INF 1000000000
using namespace std ;

struct Edge{
	int x , y , w ;
}edge[MAX*MAX];

bool cmp(const Edge &e1 , const Edge &e2)
{
	return e1.w<e2.w ;
}
int f[MAX] ;
int find(int x)
{
	int r = x ;
	while(r != f[r])
	{
		r = f[r] ;
	}
	int temp ;
	while(x != f[x] )
	{
		temp = f[x] ;
		f[x] = r ;
		x = temp ;
	}
	return r ;
}

void init()
{
	for(int i = 0 ; i < MAX ; ++i)
	{
		f[i] = i ; 
	}
}

int kruskal(int n , int m)
{
	sort(edge,edge+n,cmp) ;
	init();
	int sum = 0 ,count = 0;
	for(int i = 0 ; i < n ; ++i)
	{
		int x = find(edge[i].x) , y = find(edge[i].y) ;
		if(x != y)
		{
			count++ ;
			sum += edge[i].w;
			f[x] = f[y] ;
		}
	}
	if(count<m-1)
	{
		return INF ;
	}
	return sum ;
}

int main()
{
	int t ;
	scanf("%d",&t);
	while(t--)
	{
		int n , m , k;
		scanf("%d%d%d",&n,&m,&k) ;
		int index = 0 ;
		for(int i = 0 ; i < m ; ++i)
		{
			int x, y ,w ;
			scanf("%d%d%d",&x,&y,&w) ;
			edge[index].x = x , edge[index].y = y , edge[index++].w = w ;
		}
		int p[MAX] ;
		for(int i = 0 ; i < k ; ++i)
		{
			int t ;
			scanf("%d",&t);
			for(int j = 0 ; j < t ; ++j)
			{
				scanf("%d",&p[j]);
			}
			for(int j = 0 ; j < t ; ++j)
			{
				for(int r = 0 ; r < j ; ++r)
				{
					edge[index].x = p[j] , edge[index].y = p[r] , edge[index++].w = 0 ;
				}
			}
		}
		int sum = kruskal(index,n) ;
		if(sum >= INF)
		{
			puts("-1") ;
		}
		else
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}


与君共勉
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值