hdu 2489 Minimal Ratio Tree DFS枚举点+最小生成树 属于中等偏上题 ,Double比较大小的时候注意精度问题

154 篇文章 1 订阅
50 篇文章 0 订阅

Minimal Ratio Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2835    Accepted Submission(s): 841


Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.




Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
 

Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.



All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.

 

Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
 

Sample Input
  
  
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0
 

Sample Output
  
  
1 3 1 2

转载请申明:  http://blog.csdn.net/lionel_d

写代码的时候,,总是犯SB的错误!!!导致wrong了好长时间!!一直以为是精度错了,,o(╯□╰)o
先枚举m个 点,,再求这m个点的最小生成树,,就可以了,,一开始我是先求n个点的最小生成树,再从树上枚举m个点,,,结果老是wrong,后来看别人的题解,,才明白自己的思路错了很严重啊!!!

看代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 20
#define INF 100000000

using namespace std ;

int graph[MAX][MAX] , lowCost[MAX] , node[MAX] , path[MAX] , temp[MAX];
int n ,m ;

bool cmp(const int a , const int b)
{
	return a<b ;
}
int prim(int s)
{
	bool visited[MAX] ;
	memset(visited,false,sizeof(visited)) ;
	int sum = 0 ;
	for(int i = 0 ; i < m ; ++i)
	{
		lowCost[temp[i]] = graph[s][temp[i]] ;
	}
	visited[s] = true ;
	for(int i = 0 ; i < m-1 ; ++i)
	{
		int min = INF , index = -1 ;
		for(int j = 0 ; j < m ; ++j)
		{
			if(!visited[temp[j]] && lowCost[temp[j]]<min)
			{
				min = lowCost[temp[j]] ;
				index = temp[j] ;
			}
		}
		if(index == -1)
		{
			break ;
		}
		visited[index] = true ;
		sum += min ;
		for(int j = 0 ; j < m ; ++j)
		{
			if(!visited[temp[j]] && lowCost[temp[j]]>graph[index][temp[j]])
			{
				lowCost[temp[j]] = graph[index][temp[j]] ;
			}
		}
	}
	return sum ;
}
double ans = INF*1.0 ;
void DFS(int num , int count)
{
	if(count == m)
	{
		int sumOfEdge = prim(temp[0]) ,sumOfNode = 0;
		for(int i = 0 ; i < m ; ++i)
		{
			sumOfNode += node[temp[i]] ;
		}
		double t = sumOfEdge*1.0/sumOfNode ;
		if(ans-t>0.00001)
		{
			ans = t ;
			for(int i = 0 ; i < m ; ++i)
			{
				path[i] = temp[i] ;
			}
		}
		return ;
	}
	for(int i = num+1 ; i <= n ; ++i)
	{
		temp[count] = i ;
		DFS(i,count+1);
	}
}

int main()
{
	while(~scanf("%d%d",&n,&m) && (m||n))
	{
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d",&node[i]) ;
		}
		for(int i = 1 ;i <= n ; ++i )
		{
			for(int j = 1 ; j <= n ; ++j)
			{
				scanf("%d",&graph[i][j]) ;
			}
			graph[i][i] = INF ;
		}
		ans = INF*1.0 ;
		for(int i = 1 ; i <= n ; ++i)
		{
			temp[0] = i ;
			DFS(i,1);
		}
		sort(path,path+m,cmp) ;
		for(int i = 0 ; i < m ; ++i)
		{
			printf("%d",path[i]) ;
			if(i != m-1)
			{
				printf(" ") ;
			}
		}
		puts("") ;
	}
	return 0 ;
}

与君共勉
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值