hdu 1429 胜利大逃亡(续) 搜索+状态压缩,,不错的题。

154 篇文章 1 订阅
33 篇文章 0 订阅

胜利大逃亡(续)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5860    Accepted Submission(s): 2046


Problem Description
Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)……

这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了带锁的门,钥匙藏在地牢另外的某些地方。刚开始Ignatius被关在(sx,sy)的位置,离开地牢的门在(ex,ey)的位置。Ignatius每分钟只能从一个坐标走到相邻四个坐标中的其中一个。魔王每t分钟回地牢视察一次,若发现Ignatius不在原位置便把他拎回去。经过若干次的尝试,Ignatius已画出整个地牢的地图。现在请你帮他计算能否再次成功逃亡。只要在魔王下次视察之前走到出口就算离开地牢,如果魔王回来的时候刚好走到出口或还未到出口都算逃亡失败。
 

Input
每组测试数据的第一行有三个整数n,m,t(2<=n,m<=20,t>0)。接下来的n行m列为地牢的地图,其中包括:

. 代表路
* 代表墙
@ 代表Ignatius的起始位置
^ 代表地牢的出口
A-J 代表带锁的门,对应的钥匙分别为a-j
a-j 代表钥匙,对应的门分别为A-J

每组测试数据之间有一个空行。
 

Output
针对每组测试数据,如果可以成功逃亡,请输出需要多少分钟才能离开,如果不能则输出-1。
 

Sample Input
  
  
4 5 17 @A.B. a*.*. *..*^ c..b* 4 5 16 @A.B. a*.*. *..*^ c..b*
 

Sample Output
  
  
16 -1
 
因为只有10把钥匙,那么可以把10钥匙压缩二进制,比如1000就表示身上只有第4把钥匙,110表示带有第2把和第3把钥匙,那么要判断当前的钥匙串有没有能打开当前门钥匙,那么就只要一个&运算就可以,因为11101110&00100000==00100000 这样就说明那一把钥匙在里面,若为0就不在这里面。如果对于当前点是一把钥匙的时候,只要|运算就可以了,11101110 | 00010000 z这样就把当前这把钥匙放进了钥匙串里面了
想通了,这道题还是不难的。
代码:
#include <iostream>
#include <queue>
#include <cstring>

using namespace std ;
struct Node{
	int x , y ;
	int time , key ;
};
bool visited[25][25][1050] ;
char map[25][25] ;
int n , m , lim;
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}} ;
bool judge(Node t)
{
	if(t.x<0||t.y<0 || t.x>=n||t.y>=m)
	{
		return false ;
	}
	return true ;
}
int bfs(int x , int y )
{
	queue<Node> que ;
	Node s ;
	s.x = x , s.y = y ;
	s.time = s.key = 0 ;
	que.push(s) ;
	memset(visited,false,sizeof(visited)) ;
	while(!que.empty())
	{
		s = que.front() ;
		que.pop() ;
		if(map[s.x][s.y] == '^' && lim>s.time)
		{
			return s.time ;
		}
		if(lim<=s.time)	break ;
		for(int i = 0 ; i < 4 ; ++i)
		{
			Node next ;
			next.x = s.x+dir[i][0] ;
			next.y = s.y+dir[i][1] ;
			next.time = s.time + 1 ;
			next.key = s.key ;
			if(!judge(next) || map[next.x][next.y] == '*')
				continue ;
			if(!visited[next.x][next.y][next.key])
			{
				if(map[next.x][next.y]>='A' && map[next.x][next.y]<='J')
				{
					if(next.key&(1<<(map[next.x][next.y]-'A')))
					{
						que.push(next) ;
						visited[next.x][next.y][next.key] = true ;
					}
				}
				else if(map[next.x][next.y]>='a' && map[next.x][next.y]<='j')
				{
					next.key = next.key|(1<<(map[next.x][next.y]-'a')) ;
					que.push(next) ;
					visited[next.x][next.y][next.key] = true ;
				}
				else
				{
					que.push(next) ;
					visited[next.x][next.y][next.key] = true ;
				}
			}
		}
	}
	return -1 ;
}

int main()
{
	while(cin>>n>>m>>lim)
	{
		int x, y ;
		for(int i = 0 ; i < n ; ++i)
		{
			cin>>map[i] ;
		}
		for(int i = 0 ; i < n ; ++i)
			for(int j = 0 ; j < m ; ++j)
			{
				if(map[i][j] == '@')
				{
					x = i , y = j ;
					break ;
				}
			}
		int ans = bfs(x,y) ;
		cout<<ans<<endl ;
	}
	return 0 ;
}

与君共勉
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值