POJ3321:Apple Tree DFS序+树状数组

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong


题意:
给出一个苹果树,每个节点一开始都有苹果
C X,如果X点有苹果,则拿掉,如果没有,则新长出一个
Q X,查询X点与它的所有后代分支一共有几个苹果


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;
#define N 100005
#define lowbit(x) (x&-x)
vector<vector<int> > a(N);
int n,m,lef[N],rig[N],c[N],tot,s[N];
int sum(int x)
{
    int ret = 0;
    while(x>0)
    {
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}


void add(int x,int d)
{
    while(x<=n)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}




void dfs(int x)
{
    lef[x] = tot;
    for(int i = 0; i<a[x].size(); i++)
    {
        tot++;
        dfs(a[x][i]);
    }
    rig[x] = tot;
}
int main()
{
    int i,j,k,x,y;
    char op[5];
    while(~scanf("%d",&n))
    {
        memset(lef,0,sizeof(lef));
        memset(rig,0,sizeof(rig));
        memset(s,0,sizeof(s));
        memset(c,0,sizeof(c));
        for(i=0; i<N; i++)
            a[i].clear();
        for(i = 1; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            a[x].push_back(y);
        }
        tot = 1;
        dfs(1);
        for(i = 1; i<=n; i++)
        {
            s[i] = 1;
            add(i,1);
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%d",op,&x);
            if(op[0]=='Q')
            {
                printf("%d\n",sum(rig[x])-sum(lef[x]-1));
            }
            else
            {
                if(s[x])
                    add(lef[x],-1);
                else
                    add(lef[x],1);
                s[x]=!s[x];
            }
        }
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值