山东第一届acm Greatest Number 二分+数字处理

Problem Description
Saya likes math, because she think math can make her cleverer.
One day, Kudo invited a very simple game:
Given N integers, then the players choose no more than four integers from them (can be repeated) and add them together. Finally, the one whose sum is the largest wins the game. It seems very simple, but there is one more condition: the sum shouldn’t larger than a number M.
Saya is very interest in this game. She says that since the number of integers is finite, we can enumerate all the selecting and find the largest sum. Saya calls the largest sum Greatest Number (GN). After reflecting for a while, Saya declares that she found the GN and shows her answer.
Kudo wants to know whether Saya’s answer is the best, so she comes to you for help.
Can you help her to compute the GN?
Input
The input consists of several test cases.
The first line of input in each test case contains two integers N (0<N≤1000) and M(0
1000000000), which represent the number of integers and the upper bound.
Each of the next N lines contains the integers. (Not larger than 1000000000)
The last case is followed by a line containing two zeros.
Output
For each case, print the case number (1, 2 …) and the GN.
Your output format should imitate the sample output. Print a blank line after each test case.
Sample Input
2 10
100
2

0 0
Sample Output
Case 1: 8
Hint
 
Source

2010年山东省第一届ACM大学生程序设计竞赛 


给你n个数,要求用小于等于4个组成一个尽量等于m,但绝对不能大于m的数。

我们利用二分来做。

我们现存下1个的情况,那就是输入数据。还有0,这一个特殊值。

之后双重循环,在存下两两相加的情况。

之后3个的和4个的我们都可以通过1个的和2个的相加得到。而1个的,2个的,通过和特殊值0相加,也能找到。

所以我们就是存下0,1,2的。之后for枚举每一个值,二分另外一个值。累加查找尽量等于m的值即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<string.h>
#include<vector>
using namespace std;
int n,m,k;
int u;
int a[1100000];
int main()
{
    int tt=0;
    while(scanf("%d%d",&n,&m)!=EOF&&n&&m)
    {
        tt++;
        k=1;
        a[0]=0;
        for(int i=1;i<=n;i++)
        {
            cin>>u;
            if(u>m)
            {
                continue;
            }
            else
            {
                a[k++]=u;
            }
        }
        int len=k;
        for(int i=0;i<len;i++)
        {
            for(int j=0;j<len;j++)
            {
                int u=a[i]+a[j];
                if(u>m)
                {
                    continue;
                }
                a[k++]=a[i]+a[j];


            }
        }
        sort(a,a+k);
        //此时a保存着 0,1个的,两个的
        int ans=-1;
        for(int i=0;i<k;i++)
        {
            int l=0;
            int r=k;
            while(l<r)
            {
                int mid=(l+r)/2;
                if(a[i]+a[mid]<=m)
                {
                    ans=max(ans,a[i]+a[mid]);
                    l=mid+1;
                }
                else
                {
                    r=mid;
                }


            }


        }
        cout<<"Case "<<tt<<": ";
        cout<<ans<<endl;
        cout<<endl;


    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值