POJ 3069 贪心

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output
For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4

求每段区间的中间位置,先扫左边,从第一个军队位置开始,扫到n区间内的最后一个军队的位置,把灯塔放这,再扫右边区间的最后一个位置。由于是对称结构,一次扫一对区间才能求出来,并不是每个区间独立,所以在while里面要每次都判断左右两区间,这就简单很多了。像我这种新手,刚开始白痴的想着,每次只判断一次区间。根本不可能做出来。要学会用纸画图解题,看题是没用的的。

#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <stack>
#include <cstdio>
using namespace std;
int a[1010];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF&&n!=-1&&m!=-1)
    {
        int i;
        for(i=0;i<m;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+m);
        i=0;
        int sum=0;
        while(i<m)
        {
            int s=a[i++];
            while(i<m&&a[i]<=s+n) i++;
            int p=a[i-1];
            while(i<m&&a[i]<=p+n) i++;
            sum++;
        }
        printf("%d\n", sum);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值