poj 1458 最长公共子序列

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0

求最长公共子序列
状态转移方程
dp[i][j] 是在i的当前字符,和j的当前字符相对于前面 1~i-1 1~j-1里面最长的公共子序列。
因为题目要求的公共子序列的两个条件是 在s里面是有次序的,在s2里面也是有次序,过了的不能再被选择,只能不断往后选。相当于两个上升序列合并,但是选择条件改变了。而那些不相同的 保持的是上一个相同的最大值。
遇到两个相同的值,dp[i][j] 由s的上一个字符阶段 i-1 里面选择 j在1~j-1字符里面的最长公共序列里面选择最长的dp,由于j-1是j在 1到j-1里面最长的 所以 dp[i-1][j-1]是上一个相同字符里面最长的。
为什么j-1 是1~j-1里面最长的 因为 dp[i][j] =max(dp[i-1][j],dp[i-1][j-1]),从而得到无论是i的上一阶段还是当前阶段i也是最长的,而且
与(1~j-1)也是最长的那个。
if(s[i]==s2[j])
dp[i][j]=dp[i-1][j-1]+1;
else
{ dp[i][j] = max(dp[i-1][j],dp[i][j-1]);}

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
#define fi first
#define se second
#define ff(i,a,b) for(int i = a; i <= b; i++)
#define f(i,a,b) for(int i = a; i < b; i++)
typedef pair<int,int> P;
#define ll long long
int dp[1010][1010];
char s1[1010],s2[1010];
int main()
{
    // ios::sync_with_stdio(false);
    while(scanf(" %s %s", s1 + 1, s2 + 1) != EOF)
    {
    	memset(dp,0,sizeof(dp));
	    int maxx = 0;
	    int len1 = strlen(s1 + 1),len2 = strlen(s2 + 1);
	    ff(i,1,len1) ff(j,1,len2)
	    {
    		dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
    		if(s1[i] == s2[j]) dp[i][j] = max(dp[i][j], dp[i - 1][j - 1] + 1);
	    }

	    cout << dp[len1][len2] << endl;
    }
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值