codeforces 628B New Skateboard

Max wants to buy a new skateboard. He has calculated the amount of money that is needed to buy a new skateboard. He left a calculator on the floor and went to ask some money from his parents. Meanwhile his little brother Yusuf came and started to press the keys randomly. Unfortunately Max has forgotten the number which he had calculated. The only thing he knows is that the number is divisible by 4.

You are given a string s consisting of digits (the number on the display of the calculator after Yusuf randomly pressed the keys). Your task is to find the number of substrings which are divisible by 4. A substring can start with a zero.

A substring of a string is a nonempty sequence of consecutive characters.

For example if string s is 124 then we have four substrings that are divisible by 4: 12, 4, 24 and 124. For the string 04 the answer is three: 0, 4, 04.

As input/output can reach huge size it is recommended to use fast input/output methods: for example, prefer to use gets/scanf/printf instead of getline/cin/cout in C++, prefer to use BufferedReader/PrintWriter instead of Scanner/System.out in Java.

Input
The only line contains string s (1 ≤ |s| ≤ 3·105). The string s contains only digits from 0 to 9.

Output
Print integer a — the number of substrings of the string s that are divisible by 4.

Note that the answer can be huge, so you should use 64-bit integer type to store it. In C++ you can use the long long integer type and in Java you can use long integer type.

Example
Input
124
Output
4
Input
04
Output
3
Input
5810438174
Output
9

Description
给出一个数字串,问这个数字串的子串中能整除4的子串数(子串可以包括前置0)
Input
一个数字串,长度不超过3*10^5
Output
输出该串能整除4的子串数量
Sample Input
124
Sample Output
4

任何一个数能写成a*100+b,如632=6*100+32
其中100整除4,所以a*100可整除4,只要b能整除4(即后两位可整除4),则a*100+b整除4
即原数整除4

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5*3+10;

char s[maxn];
int main()
{
    gets(s);
    int len=strlen(s);
    long long ans=0;
    for(int i=0;i<len;i++)
    {
        int res=(s[i-1]-'0')*10+s[i]-'0';
        if((s[i]-'0')%4==0){
            ans++;
        }
         if(res%4==0)
        {
        ans+=i;
        }
    }
    cout<<ans<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值