hdu 5873 Football Games 思维

Football Games
A mysterious country will hold a football world championships—Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced.

At the first phase of the championships, teams are divided into MM groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.

When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups’ scores must be false.
Input
Multiple test cases, process till end of the input.

For each case, the first line contains a positive integers MM, which is the number of groups.
The ii-th of the next MM lines begins with a positive integer BiBi representing the number of teams in the ii-th group, followed by BiBi nonnegative integers representing the score of each team in this group.

number of test cases <= 10
M<= 100
Bii<= 20000
score of each team <= 20000
Output
For each test case, output MM lines. Output F" (without quotes) if the scores in the i-th group must be false, outputT” (without quotes) otherwise. See samples for detail.
Sample Input
2
3 0 5 1
2 1 1
Sample Output
F
T

题意:
m个小组,每个小组n支队伍进行比赛,任意两支队伍之间有一场比赛
一场比赛里赢得+2分输的+0分,打平的话每队+1分
先给出每支队伍的得分,判断这些得分是否满足小组比赛的条件

思路:原地址
得分从小到大排序,对于当前i,与之前的i-1支队伍比赛完之后,所有的比赛的总得分至少是(i-1)*i
每场比赛都产生2分,打了(i-1)i/2场,也就是i(i-1)分
最后n场的总分为n*(n-1)

为什么要一直大于呢,因为前面的肯定是等于i*(i-1) 的 但是后面的和它打的时候有可能让他分数增加,所以是一直保持着 >= 的趋势,然后最后再判个等于就好

#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

const int N = 3e5;
int a[N];
int main()
{
    int t;
    while(scanf("%d",&t)!=EOF)
    {
    while(t--)
    {
        int n;
        scanf("%d",&n);
        ll sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int f=0;
        sort(a+1,a+n+1);
        for(int i=1;i<n;i++)
        {
            sum+=a[i];
            if(sum<(ll(i)*(i-1)))
            {
                f=1;
                break;
            }
        }
        sum+=a[n];
        if(sum!=(ll(n)*(n-1)))
            f=1;
        if(f) printf("F\n");
        else printf("T\n");
    }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值