HDOJ 1013 Digital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 70304    Accepted Submission(s): 22012


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
 

题目大意:

 给定一个正整数,根据一定的规则求出该数的数根,其规则如下:

        例如给定 数字 24,将24的各个位上的数字分离,分别得到数字 和 4,而2+4=6

        因为 6 < 10,所以就认为6是数字24数根

        而对于数字 39  将39的各个位上的数字分离,分别得到数字 和 9,而3+9=12,12>10

       所以依据规则再对 12 进行相应的运算,最后得到数字3,而3<10,所以就认为3是数字39数根

       

              通过运算可以发现任何一个数的数根都是一个取值范围在 1 ~ 9之间的正整数,

     且任何一个正整数都只有唯一的一个数根与其相对应。

              题目要求数字 n^n 数根

解题思路:

九余数定理

一个数对九取余后的结果称为九余数。

一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

#include <stdio.h>  
#include <stdlib.h>  
#include<string.h>  
int main()  
{  
    char a[1010];  
    int i,j,s,l;  
    while(~scanf("%s",&a)&&a[0]!='0')  
    {  
        l=strlen(a);  
        s=0;  
        for(i=0;i<l;i++)  
        {  
            s=s+a[i]-'0';  
        }  
        s=s%9;  
        if(s==0)  
            s=9;  
        printf("%d\n",s);  
    }  
    return 0;  
}  
下面的程序显示格式不对,我还没有找到错误 大哭,想用大数做

#include<stdio.h>
#include<string.h>
int main(){
	char a[10000];
	int alen, b[10000], sum, i;
	while(scanf("%s",a)&&strcmp(a,"0") != 0){  //学习输入字符串结束程序的方法 
		alen = strlen(a);
		sum = 0;
		for(i = 0; i < alen; i++){
			b[i] = a[i] - '0';  //字符转化为数字 
			sum += b[i];   //一个个求和 
			if(sum >= 10){   //超过10,最多不超过18 
				sum = sum%10 + sum/10; //两位数再加起来 
			}
		}
		printf("%d\n",sum);
		
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值