《动态规划》— HDU 3466 Proud Merchants(01背包+排序)

Proud Merchants

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 6255    Accepted Submission(s): 2585

 

 

Problem Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
 

 Input

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.
 

 Output

For each test case, output one integer, indicating maximum value iSea could get.
 

 Sample Input

 

2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3

 

 

Sample Output

 

5

11

题目大意:最近,isea去一个古老的国家。长时间,它是世界上最富有和最强大的王国。结果,人们在这个国家仍然是非常自豪,即使他们的国家没有那么富裕了。 商人是最典型的,他们每个人只卖一个项目,价格是Pi,但他们会拒绝和你做交易如果你的钱少于Qi,和iSea评估每一项价值。如果他有M钱,iSea最大值可以得到什么?

也就是说我们应该先买M=p-q最大的物体,然后买p-q第二大的 。。。。。  最后买最小的。。。与顺序有关的01背包,先按q-p排序再来处理

 

#include<stdio.h>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 505;

struct Node
{
	int p,q,v;
}node[maxn];

int cmp(Node a,Node b)
{
	return a.q - a.p < b.q - b.p;    //从小到大排序 
}

int main()
{
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		int dp[5005];
		int i,j;
		for(i = 0; i < n; i++)
		{
			scanf("%d%d%d",&node[i].p,&node[i].q,&node[i].v);
		}
		memset(dp,0,(m+1)*sizeof(dp[0]));
		sort(node,node+n,cmp);
		for(i = 0; i < n; i++)
		{
			for(j = m; j >= node[i].q; j--)
			{
				dp[j] = max(dp[j],dp[j-node[i].p]+node[i].v);
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}

 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值