《字符串》— HDU 3336 Count the string(KMP+求给定字符串含前缀的数量)

Count the string

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9931    Accepted Submission(s): 4643

 

 

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

 

 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

 

Sample Input

 

1 4 abab

 

 

Sample Output

 

6

 

 

Author

foreverlin@HNU

 

 

Source

HDOJ Monthly Contest – 2010.03.06

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1686 1358 3341 2222 3068 

 

#include<stdio.h>
#include<string.h>

int n,m;
char b[200010];
int p[200010];

//生成匹配表 
void get_p()
{
	p[1] = 0;
	int i,j = 0;
	for(i = 2; i <= m; i++)
	{
		while(j > 0 && b[j+1] != b[i])
		{
			j = p[j];
		}
		if(b[j+1] == b[i])
		{
			j += 1;
		}
		p[i] = j;
	}
}

int dp[2000010];
int main()
{
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&m);
		scanf("%s",b+1);
		get_p();
		dp[0] = 0;
		int sum = 0;
		for(i = 1; i <= m; i++)
		{
			dp[i] = dp[p[i]] + 1;     //含前缀的数量 
			sum = (sum+dp[i])%10007;   //注意输出格式 
		}
		printf("%d\n",sum);
	}
}
//示例解析:
a b a b
0 0 1 1      m+1+1=6   注意循环的使用 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值