NYOJ 159 I Think I Need a Houseboat

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述
Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.) 

输入
The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.
输出
For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”
样例输入
2
1.0 1.0
25.0 0.0
样例输出
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

hint
1.No property will appear exactly on the semicircle boundary: it will either be 
inside or outside. 
2.This problem will be judged automatically. Your answer must match exactly, 
including the capitalization, punctuation, and white-space. This includes the periods 
at the ends of the lines. 
3.All locations are given in miles.
来源
POJ
上传者

iphxer


/*
**类型:入门级题目
**题目来源:NYOJ  159
**时间:2017/7/22
**解决方案:面积以每年50扩展,对比点在圆上的面积/2/50  为年 。
** No property will appear exactly on the semicircle boundary: it will either be 
   inside or outside   不在圆边界. 
*/
#include<stdio.h>
int main()
{
	int T;
	scanf("%d",&T);
	int count = 1;  //设置一个计数器 
	while(T--)
	{
		
		double x, y;
		scanf("%lf%lf",&x,&y);
		
		printf("Property %d: This property will begin eroding in year %d.\n",count,(int)(3.1415926*(x*x+y*y)/100)+1);
		count++;
		
	} 	
	printf("END OF OUTPUT.\n");
	return 0;
}

//如果要考虑在圆边界上,又当如何处理 

 
*
**类型:入门级题目
**题目来源:ZOJ
**时间:2017/7/20
**解决方案:
*/
#include<stdio.h>
#include<math.h>
int main()
{
	double Pi = 3.1415926;
    double x, y, area, r;
	int N;
	scanf("%d",&N);
	for(int i = 1; i <= N; i++)
	{
		scanf("%lf%lf",&x,&y);    
		r = sqrt(x*x+y*y);
		area = r*r*Pi;
		int temp = area / 100 ;
		printf("Property %d: This property will begin eroding in year %d.\n",i,temp+1);	
	} 
	printf("END OF OUTPUT.\n");
	return 0;
}
//定义变量时,double  lf   float f 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值