codeup---------100000575_E

问题 E: Shortest Distance (20)
[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB

题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入 Copy
5 1 2 4 14 9
3
1 3
2 5
4 1
样例输出 Copy
3
10
7
先前的代码总是超时,可能是时间的复杂度比较高,后来发现一种更加简单的算法,就解决了这个问题。
先前的代码:

#include <iostream>
using namespace std;
#define MAX 100001
int main() {
    int a[MAX];
    int x,y,t,temp,n;
        cin>>n;
    	int sum=0;
    	for(int i=0;i<n;i++){
    		cin>>a[i];
    		sum+=a[i];
		}
		cin>>t;
		for(int i=0;i<t;i++){
		cin>>x>>y;
		if(x>y){
			temp=x;
			x=y;
			y=temp;
		}
		int sum1=0;
		for(int i=x-1;i<=y-2;i++){
			sum1+=a[i];
		}
		if((sum-sum1)<sum1){
			cout<<sum-sum1<<endl;
		}else{
			cout<<sum1<<endl;
		}	
		}	
}

之前把任意一个的点的距离先一个一个加上,最后发现效果图是超时,查明原因后改进后,把一些费时间的代码做了优化,最后成功AC.
效果图:
在这里插入图片描述
最后改进的代码:

#include <iostream>
using namespace std;
#define MAX 100001
int main() {
    int a[MAX];
    int dis[MAX];
    int x,y,t,temp,n;
        cin>>n;
    	int sum=0;
    	for(int i=0;i<n;i++){
    		dis[i]=sum; 
    		cin>>a[i];
    		sum+=a[i];
		}
		cin>>t;
		for(int i=0;i<t;i++){
		cin>>x>>y;
		if(x>y){
			temp=x;
			x=y;
			y=temp;
		}
		int sum1=dis[y-1]-dis[x-1];
		if((sum-sum1)<sum1){
			cout<<sum-sum1<<endl;
		}else{
			cout<<sum1<<endl;
		}	
		}	
}

就是把任一点到第一个点的距离算出来,最后在进行遍历的时候就大大的加强的算法的速度,从而使算法整体优化了。
改进后AC效果图:
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值