poj 2406 Power Strings (KMP)

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

初学KMP,先做些题目来熟悉,这道题需要注意的地方就是

1、字符数组的长度不要开小了

2、代码中的注释那一部分,一开始没理解题目意思,后来想了很久才明白过来。

代码如下:

#include <stdio.h>
#include <string.h>
char a[1000005];
int next[1000005];
int n;
int kmp()
{
    int j=-1;
    next[0]=-1;
    n=strlen(a);
    for(int i=0;i<n;)
    {
        if(j==-1||a[i]==a[j])    next[++i]=++j;
        else                     j=next[j];
    }
    if(n%(n-next[n])==0)         printf("%d\n",n/(n-next[n]));//n-next(n)是一个周期的长度,若n%它是一个整数的时候,说明可以写成(a)^n的形式,再用长度/周期长度来求有多少个周期就可以了
    else                         printf("1\n");
}
int main()
{


    while(scanf("%s",a),a[0]!='.')
    {
        kmp();
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值