POJ-3687-Labeling Balls(拓扑排序+自闭题意(跟以往做的不同))

Labeling Balls

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16510 Accepted: 4844

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5
4 0
4 1
1 1
4 2
1 2
2 1
4 1
2 1
4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

 

题意:非常重要!!!

之前题目是告诉你某些质量关系,然后让你根据质量关系求出他们的排序顺序,让1尽可能靠前,让后2尽可能靠前...
这道题目是告诉你某些质量关系,然后让你根据质量关系,求出每个东西的质量大小,编号为1的质量尽可能小,然后编号为2的质量尽可能小...输出每个物品的质量!!!!

题解:

这道题的思路就肯定是跟之前那种题目一样,先反向建图,放入最大值优先的优先队列中,先弹出的必定是已经满足约束条件并且最大的,那么这个物品的质量选取当前剩余质量中质量最大的,然后以当前优先队列中弹出的物品序号为下标,当前剩余可选取的最大质量为变量值构成答案数组,具体看代码吧,很好理解的

代码:

/*真的自闭的一个题目,因为之前几道题目做的都是拓扑排序输出编号顺序的,而这个题目输出的从1~n个编号的重量是多少,然后尽可能满足编号为1的尽量小,然后为2的又尽量小...
即之前题目是告诉你某些质量关系,然后让你根据质量关系求出他们的排序顺序,让1尽可能靠前,让后2尽可能靠前...
这道题目是告诉你某些质量关系,然后让你根据质量关系,求出每个东西的质量大小,编号为1的质量尽可能小,然后编号为2的质量尽可能小...输出每个物品的质量
那么这道题的思路就肯定是跟之前那种题目一样,先反向建图,放入最大值优先的优先队列中,先弹出的必定是已经满足约束条件并且最大的,那么这个物品的质量选取当前剩余质量中质量最大的*/
#include<queue>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#include<map>
#include<string>
#define N 40005
using namespace std;
int t,n,m,k;
int in[N],ans[N];
vector<int>v[N];
bool vis[205][205];
struct cmp
{
	bool operator () (int &a,int &b)
	{
		return a<b;
	}
};
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		k=n;
		for(int i=1;i<=n;i++)v[i].clear();
		memset(in,0,sizeof(in));
		memset(ans,0,sizeof(ans));
		memset(vis,0,sizeof(vis));
		priority_queue<int,vector<int>,cmp>q;
		while(!q.empty())q.pop();
		// memset(vis,0,sizeof(vis));
		for(int i=1;i<=m;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			if(!vis[y][x])
			{
				vis[y][x]=1;
				v[y].push_back(x);
				in[x]++;
			}
		}
		for(int i=1;i<=n;i++)
		{
			if(in[i]==0)
			{
				q.push(i);
			}
		}
		while(!q.empty())
		{
			int now=q.top();
			q.pop();
			ans[now]=k;
			k--;
			// k++;
			// ans[k]=now;
			for(int i=0;i<v[now].size();i++)
			{
				int next=v[now][i];
				in[next]--;
				if(in[next]==0)
				{
					q.push(next);
				}
			}
		}
		if(k!=0)printf("-1\n");
		else
		{
			for(int i=1;i<=n;i++)
				printf("%d%c",ans[i],i==n?'\n':' ');
		}
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值