POJ-2342-Anniversary party(树形DP模板题)

Anniversary party

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13011 Accepted: 7426

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意:经典树形DP,没有上司的舞会,n个人存在一些关系,每个人都有满意度,某些人是某些人的上司,参加一个舞会,但是直系上司参加,他就不能参加,求最大的满意度

题意分析:经典树形DP,状态方程f[i][1]+=f[j][0]   f[i][0]+=max(f[j][0],f[j][1]),代码里面有解释,可以看看

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<string>
#include<algorithm>
#define N 6005
using namespace std;
int n,x,y,s;
int a[N],f[N][2],in[N];
vector<int>v[N];
void dfs(int x)
{
	// f[x][1]=a[x];//写成这样也行,最开始的时候就把他去的价值加上
	for(int i=0;i<v[x].size();i++)
	{
		int nex=v[x][i];
		dfs(nex);
		f[x][0]+=max(f[nex][0],f[nex][1]);//在这里必须写成自加的形式,不能直接用等于,因为我自己本身也有价值,而且还有很多个儿子节点也有价值
		f[x][1]+=f[nex][0];
		/*
		f[x][0]=max(f[nex][0],f[nex][1]);
		f[x][1]=f[nex][0]+a[x];
		*/
		//不能写成这样的,因为我碰到叶子节点的时候,我的f[x][1]是没被更新的
		//就算我搭配后面的语句,但是我可能当前这个节点有很多的儿子节点,那么我这里的这个父亲节点只能得到其中最后一个儿子节点的价值
		
	}
	f[x][1]+=a[x];//在最后的时候加上也行,先把他的员工的价值算上
	/*if(v[x].size()==0)
		f[x][1]=a[x];*/
}
int main()
{
	scanf("%d",&n);
	memset(in,0,sizeof(in));
	memset(f,0,sizeof(f));
	for(int i=1;i<=n;i++)scanf("%d",&a[i]);
	while(scanf("%d%d",&x,&y)&&x!=0&&y!=0)
	{
		v[y].push_back(x);
		in[x]++;
	}
	for(int i=1;i<=n;i++)
		if(in[i]==0)
		{
			s=i;
			break;
		}
	dfs(s);
	/*for(int i=1;i<=n;i++)
	{
		cout<<f[i][0]<<" "<<f[i][1]<<endl;
	}*/
	printf("%d",max(f[s][0],f[s][1]));
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值