POJ - 1463-Strategic game(树形DP+横向建图)

Strategic game

Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 10734 Accepted: 5048

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 


  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意:一颗树,让你找最少的节点把树上所有的节点都能监控到,父节点可以监控子节点

题意分析:树形DP,横向建图,状态转移方程f[x][1]+=min(f[nex][1],f[nex][0]);    f[x][0]+=f[nex][1];   表述能力不行,具体的都在代码里面了

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#define N 2005
#define INF 0x3f3f3f3f
using namespace std;
int n,x,k,y,s,ans;
char c1,c2,c3;
int f[N][2],in[N],brother[N],son[N];
/*
void dfs(int x)
{
	for(int i=0;i<v[x].size();i++)
	{
		int nex=v[x][i];
		dfs(nex);
		f[x][1]+=max(f[nex][0],f[nex][1]);
		if(f[nex][1]>f[nex][0])num[x][1]+=num[nex][1];
		else num[x][1]+=num[nex][0];
		f[x][0]+=f[nex][1];
	}
	f[x][1]+=1;
	num[x][1]++;
}*/
void dfs(int x)
{
	f[x][1]=1;
	f[x][0]=0;
	int nex=son[x];//先找到自己的最后一个儿子,然后再横向找其他的儿子
	while(nex!=-1)
	{
		dfs(nex);
		f[x][1]+=min(f[nex][1],f[nex][0]);
		f[x][0]+=f[nex][1];
		//很多人好奇有很多个儿子的时候怎么办,实际上,当我当前父节点不选择时,我当前父节点就必须加上子节点选的值(没得选择)
		//而当我父节点选择时,我可以子节点不选择
		//当我有一个子节点被选择时,父节点可以选择不选,但是别的儿子节点必须被选择
		//会有个疑惑就是,我这个点选了,我的子节点可以不选或者选,如果是不选,那么子节点的子节点就必须选,那么当前的子节点的F[NEX][0]是有别的值的
		//是从最后面一层一层递归来的,所以后面子节点的答案就会被储存下来
		nex=brother[nex];//纵向遍历
	}
}
int main()
{
	while(~scanf("%d",&n))
	{
		memset(f,0,sizeof(f));
		memset(in,0,sizeof(in));
		memset(brother,-1,sizeof(brother));
		memset(son,-1,sizeof(son));
		/*
		for(int i=0;i<=n;i++)v[i].clear();
		for(int i=0;i<n;i++)
		{
			cin>>x>>c1>>c2>>k>>c3;
			for(int i=1;i<=k;i++)
			{
				cin>>y;
				v[x].push_back(y);
				in[y]++;
			}
		}*/
		for(int i=1;i<=n;i++)
		{
			scanf("%d:(%d)",&x,&k);
			for(int j=1;j<=k;j++)
			{
				scanf("%d",&y);
				brother[y]=son[x];//横向遍历建图,每次都指向自己的兄弟节点
				son[x]=y;
				in[y]++;
			}
		}
		for(int i=0;i<n;i++)
			if(in[i]==0)
			{
				s=i;
				break;
			}
		dfs(s);
		printf("%d\n",min(f[s][0],f[s][1]));
		/*for(int i=0;i<n;i++)
			cout<<f[i][0]<<" "<<f[i][1]<<endl;
		cout<<max(f[s][0],f[s][1])<<endl;*/
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值