题目描述 Description
农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。
约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了用最小的消费,他想铺设最短的光纤去连接所有的农场。
你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。每两个农场间的距离不会超过100000输入描述 Input Description
第一行: 农场的个数,N(3<=N<=100)。
第二行,某些行会紧接着另一些行。当然,对角线将会是0,因为不会有线路从第i个农..结尾:
后来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们限制在80个字符,因此场到它本身。输出描述 Output Description
只有一个输出,其中包含连接到每个农场的光纤的最小长度。样例输入 Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16样例输出 Sample Output
28数据范围及提示 Data Size & Hint
暂时无范围。
题解:裸的最小生成树,用kruskal算法就可以。
代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX_V=16000;
const int MAX_E=31000;
int tot,fa[MAX_V],son[MAX_V],n;
struct edge
{
int from,to,cost;
}es[MAX_E<<1];
void init()
{
tot=0;
memset(fa,0,sizeof(fa));
memset(son,0,sizeof(son));
memset(es,0,sizeof(es));
}
bool cmp(edge a,edge b)
{
return a.cost<b.cost;
}
int find(int x)
{
return fa[x]==x?x:fa[x]=find(fa[x]);
}
bool join(int x,int y)
{
int root1,root2;
root1=find(x);
root2=find(y);
if(root1==root2) return false;
else if(son[root1]>=son[root2])
{
fa[root2]=root1;
son[root1]+=son[root2];
}
else
{
fa[root1]=root2;
son[root2]+=son[root1];
}
return true;
}
void kruskal()
{
int ltotal=0,flag=0,sum=0;
for(int i=1;i<=n;i++)
{
fa[i]=i;
son[i]=1;
}
sort(es+1,es+tot+1,cmp);
for(int i=1;i<=tot;i++)
{
if(join(es[i].from,es[i].to))
{
ltotal++;
sum+=es[i].cost;
}
if(ltotal==n-1)
{
flag=1;
break;
}
}
if(flag) printf("%d\n",sum);
}
int main()
{
scanf("%d",&n);
init();
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
int o;
scanf("%d",&o);
if(o!=0)
{
es[++tot].from=i;
es[tot].to=j;
es[tot].cost=o;
}
}
kruskal();
return 0;
}