HDU 4081 Qin Shi Huang's National Road System 次小生成树

47 篇文章 0 订阅
4 篇文章 0 订阅
Qin Shi Huang's National Road System
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7084    Accepted Submission(s): 2509


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.


Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.


Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.


Sample Input

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40



Sample Output

65.00
70.00



Source
2011 Asia Beijing Regional Contest

题意就是 n个城市修n-1条路 可以让一条路免费
A=免费的路连接的2个城市人口之和
B=除去免费的路外 其他的路的总长度
求A/B的最大值


考虑穷举图G中每一条边作为免费边
a,b为边e连接的2个城市 w为权值
确定了免费边 A的值也就确定了 然后让B尽量小
①:如果e是图G的最小生成树的中的边 那B=最小生成树的值-w
②:如果e不是最小生成树中的边 将e添加进最小生成树里 显然会形成一个包含e的环 删去环中长度最大的边 B的值最小
所以B=最小生成树的值-len[a][b]
len[a][b]为a<->b的路径中 权值最大的边的权值(不含e)
到了这里 不难发现 修改一下 次小生成树的算法即可

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

const int N=1000+5;

struct edge{
    int a,b;
    double w;
    bool selected;//是否包含在最小生成树中
};

vector<edge>vedge;
vector<int>G[N];//G[i]记录所有与i联通的点 (i所在集合的点)
pii coord[N];
int par[N];//并查集
double len[N][N];//len[i][j]:i<->j路径中权值最大的边权
int popular[N];
double mst;//最小生成树值
//double secmst;//次小生成树值

inline int find(int x){
    return x==par[x]?x:par[x]=find(par[x]);
}

inline void merge(int x,int y){
    par[find(y)]=find(x);
}

bool comp(const edge&a,const edge&b){
    if(a.w!=b.w)
        return a.w<b.w;
    if(a.a!=b.a)
        return a.a<b.a;
    return a.b<b.b;
}

inline double distance(const pii&a,const pii&b){
    return sqrt((a.first-b.first)*(a.first-b.first)+(a.second-b.second)*(a.second-b.second));
}

void kruskal(int n){
    for(int i=1;i<=n;++i){
        G[i].clear();
        G[i].push_back(i);//i所在的集合 必定包含i
        par[i]=i;//init并查集
    }
    sort(vedge.begin(),vedge.end(),comp);
    int num=0;
    mst=0;
    for(int i=0;i<vedge.size();++i){
        if(num==n-1)
            break;
        int a=find(vedge[i].a),
                b=find(vedge[i].b);
        double w=vedge[i].w;
        if(a!=b){
            ++num;
            mst+=w;
            merge(a,b);
            vedge[i].selected=true;
            for(int i=0;i<G[a].size();++i)//记录2点间最大权值
                for(int j=0;j<G[b].size();++j)
                    len[G[a][i]][G[b][j]]=len[G[b][j]][G[a][i]]=w;
            int tmpsize=G[a].size();//合并2个集合
            for(int i=0;i<G[b].size();++i)
                G[a].push_back(G[b][i]);
            for(int i=0;i<tmpsize;++i)
                G[b].push_back(G[a][i]);
        }
    }
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
            scanf("%d%d%d",&coord[i].first,&coord[i].second,&popular[i]);
        vedge.clear();
        for(int i=1;i<=n;++i)
            for(int j=i+1;j<=n;++j)
                vedge.push_back({i,j,distance(coord[i],coord[j]),false});
        kruskal(n);
        double ans=0;
        for(int i=0;i<vedge.size();++i){
            double a=popular[vedge[i].a]+popular[vedge[i].b];
            double b;
            if(vedge[i].selected)
                b=mst-vedge[i].w;
            else
                b=mst-len[vedge[i].a][vedge[i].b];
            ans=max(ans,a/b);
        }
        printf("%.2lf\n",ans);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值