POJ 1734 Sightseeing trip Floyd求最小环

36 篇文章 0 订阅
3 篇文章 0 订阅
Sightseeing trip
Time Limit: 1000MS      Memory Limit: 65536K
Total Submissions: 6539     Accepted: 2502      Special Judge

Description
There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input
The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output
There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

Source
CEOI 1999

题意:
n个点m条双向边,求图中总权值最小的环(点数>=3)
考虑dist[i][j]=i到j的最短路
如果i->j的最短路外存在一点k
且存在j->k和k->i的边 则dist[i][j]+mp[j][k]+mp[k][i]是这个环的总权值
i->j的路径再加上k 就是这个环的所有点
所以在Floyd中枚举i,j,k即可
对如下Floyd代码 显然是按照点的编号从小到大开始更新最短路dist

//Floyd代码
for(int k=1;k<=n;++k){
        for(int i=1;i<=n;++i){
            for(int j=1;j<=n;++j){
                if(dist[i][k]!=INF&&
                        dist[k][j]!=INF&&
                        dist[i][j]>dist[i][k]+dist[k][j]){
                    dist[i][j]=dist[i][k]+dist[k][j];
                    pre[i][j]=pre[k][j];
                }
            }
        }
    }

如果k>i&&k>j 且i,j,k都是环中的点
当更新了dist[i][j]时,k必然不在此i->j的路径中 因为k晚于i,j被更新
所以求最小环,可以这样:

for(int k=1;k<=n;++k){
        for(int i=1;i<=n;++i){//此时 k还没被更新,dist[i][j]中必然不经过k
            for(int j=1;j<=n;++j){
                if(dist[i][j]!=INF&&
                        mp[j][k]!=INF&&
                        mp[k][i]!=INF&&
                        i!=j&&
                        dist[i][j]+mp[j][k]+mp[k][i]<minCircle){
                    minCircle=dist[i][j]+mp[j][k]+dist[k][i];
                    updateRoad(i,j,k);//记录最短路中的点 必须马上记录 因为pre[][]以后可能被修改
                }
            }
        }
        for(int i=1;i<=n;++i){
            for(int j=1;j<=n;++j){
                if(dist[i][k]!=INF&&
                        dist[k][j]!=INF&&
                        dist[i][j]>dist[i][k]+dist[k][j]){
                    dist[i][j]=dist[i][k]+dist[k][j];
                    pre[i][j]=pre[k][j];
                }
            }
        }
    }

又因为题目要求>=3个点
如果mp[i][i]=INF,如果i!=j 再加上k便至少有3个点
AC代码:

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

char readT;
bool readIsNegative;

inline bool read(int&x){
    readIsNegative=x=0;
    while(!isdigit(readT=getchar()))
        if(readT==EOF)
            return false;
        else
            if(readT=='-'){
                readIsNegative=true;
                readT='0';
                break;
            }
    x=readT-'0';
    while(isdigit(readT=getchar()))
        x=x*10+readT-'0';
    if(readIsNegative)
        x=-x;
    return true;
}

const int N=100+5;
int mp[N][N];
int dist[N][N];
int pre[N][N];
int minCircle;
deque<int>road;

void updateRoad(int i,int j,int k){
    road.clear();
    road.push_back(j);
    while(j!=i){
        road.push_back(pre[i][j]);
        j=pre[i][j];
    }
    road.push_back(k);
}

void Floyd(int n){
    minCircle=INF;
    for(int i=1;i<=n;++i){
        for(int j=1;j<=n;++j){
            dist[i][j]=mp[i][j];
            pre[i][j]=i;
        }
    }

    for(int k=1;k<=n;++k){
        for(int i=1;i<=n;++i){
            for(int j=1;j<=n;++j){
                if(dist[i][j]!=INF&&
                        mp[j][k]!=INF&&
                        mp[k][i]!=INF&&
                        i!=j&&
                        dist[i][j]+mp[j][k]+mp[k][i]<minCircle){
                    minCircle=dist[i][j]+mp[j][k]+dist[k][i];
                    updateRoad(i,j,k);
                }
            }
        }
        for(int i=1;i<=n;++i){
            for(int j=1;j<=n;++j){
                if(dist[i][k]!=INF&&
                        dist[k][j]!=INF&&
                        dist[i][j]>dist[i][k]+dist[k][j]){
                    dist[i][j]=dist[i][k]+dist[k][j];
                    pre[i][j]=pre[k][j];
                }
            }
        }
    }
}



int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;++i)
        fill(mp[i],mp[i]+n+1,INF);
    for(int i=0,u,v,c;i<m;++i){
        scanf("%d%d%d",&u,&v,&c);
        mp[u][v]=mp[v][u]=min(mp[u][v],c);
    }
    Floyd(n);
    if(minCircle==INF)
        puts("No solution.");
    else{
        printf("%d",road[0]);
        for(int i=1;i<road.size();++i)
            printf(" %d",road[i]);
        putchar('\n');
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值