POJ 3114 Countries in War 强连通分量

Countries in War
Time Limit: 1000MS      Memory Limit: 65536K
Total Submissions: 3746     Accepted: 1083

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services, so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space, N (1 ≤ N ≤ 500) and E (0 ≤ E ≤ N2), indicating the numbers of cities (numbered from 1 to N) and of agreements on sending messages, respectively. Following them, then, E lines, each containing three integers separated by spaces, X, Y and H (1 ≤ X, Y ≤ N, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be K lines, each representing a query and containing two integers separated by a space, O and D (1 ≤ O, D ≤ N). You must determine the minimum time to send a letter from city O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The I-th line should contain an integer M, the minimum time, in hours, to send a letter in the I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0

Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0

Source
South America 2006, Brazil Subregion

题意:
从A传邮件到B需要H的时间
如果A 与 B 属于同一个国家,则不需要时间
当A能传邮件到B,B也能传邮件到A
则A,B属于同一个国家
k次查询 问邮件从O到D至少需要多少时间


显然可以对强连通分量进行缩点 然后再求最短路即可
而因为是有向无环图 所以可以通过DP 记忆化搜索 更快求解

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

const int N=500+5;
const int M=N*N;
struct Edge{
    int fr,to,next,nextRev;
    int c;
}edge[M];
int head[N],headRev[N];//原图 反向边的图
void addEdge(int k,int u,int v,int c){
    edge[k].fr=u;
    edge[k].to=v;
    edge[k].next=head[u];
    edge[k].nextRev=headRev[v];
    head[u]=headRev[v]=k;
    edge[k].c=c;
}
int visited[N];//dfs标记
int num[N];//dfs1遍历的顺序
int scc[N];//scc[i]=第i个点属于第scc[i]个强连通分量
int dfs1(int cur,int&sig){
    visited[cur]=true;
    for(int i=head[cur];i!=-1;i=edge[i].next){
        if(visited[edge[i].to]==false){
            dfs1(edge[i].to,sig);
        }
    }
    num[sig++]=cur;
    return 0;
}
int dfs2(int cur,int sig){
    visited[cur]=true;
    scc[cur]=sig;
    for(int i=headRev[cur];i!=-1;i=edge[i].nextRev){
        if(!visited[edge[i].fr]){
            dfs2(edge[i].fr,sig);
        }
    }
    return 0;
}
int kosaraju(int n){
    int sig=0;
    fill(visited,visited+n+1,false);
    for(int i=1;i<=n;++i){
        if(visited[i]==false){
            dfs1(i,sig);
        }
    }
    sig=1;
    fill(visited,visited+n+1,false);
    for(int i=n-1;i>=0;--i){
        int k=num[i];
        if(visited[k]==false){
            dfs2(k,sig++);
        }
    }
    return sig-1;
}

int newHead[N];
struct NewEdge{
    int to,c,next;
}newEdge[M];

inline void newAddEdge(int k,int u,int v,int c){
    newEdge[k].c=c;
    newEdge[k].next=newHead[u];
    newEdge[k].to=v;
    newHead[u]=k;
}

void buildG(int n,int m){
    fill(newHead,newHead+n+1,-1);
    for(int i=0,newM=0;i<m;++i){
        int u=scc[edge[i].fr],v=scc[edge[i].to];
        if(u!=v)
            newAddEdge(newM++,u,v,edge[i].c);
    }
}

int dist[N];
void dfs(int u){//记忆化搜索
    if(dist[u]!=-1)
        return;
    dist[u]=INF;
    for(int i=newHead[u];i!=-1;i=newEdge[i].next){
        dfs(newEdge[i].to);
        dist[u]=min(dist[u],dist[newEdge[i].to]+newEdge[i].c);
    }
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);
    int n,m;
    while(scanf("%d",&n),n){
        scanf("%d",&m);
        fill(head,head+n+1,-1);
        fill(headRev,headRev+n+1,-1);
        for(int i=0,u,v,c;i<m;++i){
            scanf("%d%d%d",&u,&v,&c);
            addEdge(i,u,v,c);
        }
        int newN=kosaraju(n);
        buildG(newN,m);
        int k,u,v;
        scanf("%d",&k);
        while(k--){
            scanf("%d%d",&u,&v);
            u=scc[u],v=scc[v];
            if(u==v)
                printf("0\n");
            else{
                fill(dist,dist+newN+1,-1);
                dist[v]=0;
                dfs(u);
                if(dist[u]==INF||dist[u]==-1)
                    puts("Nao e possivel entregar a carta");
                else
                    printf("%d\n",dist[u]);
            }
        }
        putchar('\n');
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值