Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44595 Accepted: 19361
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source
Ural Collegiate Programming Contest 1999
因为按Y升序 X升序顺序 输入
所以对第i个点 前i-1点如果x坐标小于x[i],则必定在第i个点左下角
所以只需要用BIT统计 前i-1个点中 x坐标<=x[i]的数量即可
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>
const int N = 15000 + 5;
const int MAX = 32000 + 5;
struct BIT{
int n;
ll c[MAX];
BIT(int n){//a[1]....a[n]
this->n = n;
for(int i=1;i<=n;++i){
c[i]=0;
}
}
void add(int k, int num){//a[k] + num
while(k<=n){
c[k]+=num;
k+=k&(-k);
}
}
ll sum(int k){//a[1]+..+a[k]
ll ans=0;
while(k){
ans+=c[k];
k-=k&(-k);
}
return ans;
}
};
int level[N];
int main()
{
//freopen("/home/lu/文档/r.txt","r",stdin);
//freopen("/home/lu/文档/w.txt","w",stdout);
int n;
while(~scanf("%d",&n)){
BIT bit(MAX);
fill(level,level+N,0);
for(int i=0;i<n;++i){
int x,y;
scanf("%d%d",&x,&y);
++x;//x有可能为0 所以这里+1
int amount = bit.sum(x);//左下角的点的数量
++level[amount];
bit.add(x,1);
}
for(int i=0;i<n;++i){
printf("%d\n",level[i]);
}
}
return 0;
}