给定两个字符串 A 和 B,本题要求你输出 A+B,即两个字符串的并集。要求先输出 A,再输出 B,但重复的字符必须被剔除。
输入格式:
输入在两行中分别给出 A 和 B,均为长度不超过 106的、由可见 ASCII 字符 (即码值为32~126)和空格组成的、由回车标识结束的非空字符串。
输出格式:
在一行中输出题面要求的 A 和 B 的和。
输入样例:
This is a sample test
to show you_How it works
输出样例:
This ampletowyu_Hrk
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include <iostream>
#include <string>
#include <cctype>
int main()
{
using namespace std;
string a;
string b;
getline(cin, a);
getline(cin, b);
int ct[255] = { 0 };
int i = 0;
char ch;
for(i = 0;i<a.size();i++)
{
ch = a[i];
if (!ct[ch+128])
{
cout.put(ch);
}
ct[a[i] + 128]++;
}
for(i = 0;i<b.size();i++)
{
ch = b[i];
if (!ct[ch + 128])
{
cout.put(ch);
}
ct[b[i] + 128]++;
}
cout.put('\n');
return 0;
}