每日三题-Day6-A(FZU 2214 Knapsack problem 01背包)

Problem 2214 Knapsack problem

Accept: 583 Submit: 2225
Time Limit: 3000 mSec Memory Limit : 32768 KB

Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

15 1512 42 21 14 101 2

Sample Output

15


题目大意:
就是01背包……


思路:
因为B太大了,如果按一般的01背包做,肯定超时。
我们可以换个思路,把用一定的容量,换取最大的价值,转换成得到一定的价值,花费的最小的容量。
也就是说,我们的dp数组,只需要5000,然后时间复杂度是O(n*sumv)【500*5000】
dp[i]代表价值为i的,最小的容量。
最后找到一个dp[i]<=B,使得i最大。这个i就是答案。

AC代码:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
long long dp[5005];
int w[505];
int v[505];
int main()
{
    int n,t;
    int q;
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        scanf("%d%d",&n,&q);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&w[i],&v[i]);
            sum+=v[i];
        }
        memset(dp,0x3f3f3f,sizeof(dp));
        dp[0]=0;
        for(int i=0;i<n;i++)
        {
            for(int j=sum;j>=v[i];j--)
            {
                dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
            }
        }
        int ans=0;
        for(int i=sum;i>=0;i--)
        {
            ans=i;
            if(dp[i]<=q)break;
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值