HDOJ1003 Max Sum_C++

 
 

Max Sum

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

    
    
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output

    
    
Case 1: 14 1 4 Case 2: 7 1 6

先贴一下超时的代码,很low的循环嵌套做的,也怪不得会超时。(真爱生命远离穷举)

#include<iostream>
#include<string>
using namespace std;
int main()
{
int num,f=1;
cin>>num;
while(num--)
{
int a[100000];
int N,sum=0,sumi=0,m;
int x=1,y=1;
cin>>N;
int i,j;
for(int i=1;i<=N;i++)
{
cin>>a[i];
}
for(i=1;i<=N;i++)
{
for(j=1;j<=N;j++)
{
for(m=i;m<=j;m++)
{

sumi+=a[m];

}
if(sumi>sum){
sum=sumi;
x=i;
y=j;
}
sumi=0;

}
}
cout<<"Case"<<" "<<f<<':'<<endl;
cout<<sum<<" "<<x<<" "<<y<<endl<<endl;
f++;
}
return 0;
 } 

穷举法它的时间复杂度O(n3),时间代价太大,所以考虑换一种方法。上网查了一下,有大佬用动态规划做的很漂亮,时间复杂度只要O(n),醍醐灌顶,重新写了段通过AC的代码。大佬好厉害!

#include <iostream>
using namespace std;
int main()
{
    int T,N,num,start,end;
    cin>>T;
    for(int k=0;k<T;k++)
    {
            cin>>N;
            int max=-1001,sum=0,temp=1;
            for(int i=0;i<N;i++)
            {
                            cin>>num;   //依次输入新元素
                            sum+=num; //sum中间数 
                            if(sum>max)  
                            {
                                       max=sum; //无论sum怎么变,max永远是当下情况的最大值,这是这个算法最厉害的地方。
                                       start=temp;
                                       end=i+1;
                            }
                            if(sum<0) //前一段小于0,抛弃前一段。换言之,只要前一段不小于0,就有存在必要。 
                            {
                                     sum=0;
                                     temp=i+2;
                            }
            }
            cout<<"Case "<<k+1<<":"<<endl<<max<<" "<<start<<" "<<end<<endl;
      if(k!=T-1) cout<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值