Additive equations(dfs)

Additive equations(dfs)

题目

We all understand that an integer set is a collection of distinct integers. Now the question is: given an integer set, can you find all its addtive equations? To explain what an additive equation is, let’s look at the following examples:
1+2=3 is an additive equation of the set {1,2,3}, since all the numbers that are summed up in the left-hand-side of the equation, namely 1 and 2, belong to the same set as their sum 3 does. We consider 1+2=3 and 2+1=3 the same equation, and will always output the numbers on the left-hand-side of the equation in ascending order. Therefore in this example, it is claimed that the set {1,2,3} has an unique additive equation 1+2=3.
It is not guaranteed that any integer set has its only additive equation. For example, the set {1,2,5} has no addtive equation and the set {1,2,3,5,6} has more than one additive equations such as 1+2=3, 1+2+3=6, etc. When the number of integers in a set gets large, it will eventually become impossible to find all the additive equations from the top of our minds – unless you are John von Neumann maybe. So we need you to program the computer to solve this problem.
Input
The input data consists of several test cases.
The first line of the input will contain an integer N, which is the number of test cases.
Each test case will first contain an integer M (1<=M<=30), which is the number of integers in the set, and then is followed by M distinct positive integers in the same line.
Output
For each test case, you are supposed to output all the additive equations of the set. These equations will be sorted according to their lengths first( i.e, the number of integer being summed), and then the equations with the same length will be sorted according to the numbers from left to right, just like the sample output shows. When there is no such equation, simply output “Can’t find any equations.” in a line. Print a blank line after each test case.
Sample Input
1
6 1 2 3 5 4 6

Sample Output
1+2=3
1+3=4
1+4=5
1+5=6
2+3=5
2+4=6
1+2+3=6

输入一个整数集合,求出在这个集合内的所有加法等式,输出时按照等式的长度排列,若长度相同则按照数字排列。

思路

采用dfs来做,a[]存放输入的整数集合,vis[i]表示a[i]是否出现在该加法等式中,sum表示和。先对输入的序列进行升序排序,然后遍历序列,找出满足相应长度的等式的加数,也就是满足sum+a[i]<=a[n-1]的,并使vis[i] = true,表示选择该数,直到找到相应等式长度个数的加数。然后再循环遍历a[],寻找该等式的和是否在这个集合中,若在,则输入该等式;若不在,则进行下一次查找。

代码

#include<cstdio>
#include<algorithm> 
#include<cstring>   

using namespace std;

int n;  //输入集合的长度
bool flag = false;  //是否能找到加法等式
int a[35];  //输入的集合
bool vis[35];   //a[i]是否出现在当前等式中

void dfs(int begin,int len,int sum)
{
    if(len==0)
    {
        for(int i=0;i<n&&sum>=a[i];i++)
        {
            if(sum==a[i])
            {
                flag = true;
                for(int j=0;j<=i;j++)
                {
                    if(vis[j])
                    {
                        if(sum == a[j])
                        {
                            printf("%d=%d\n",a[j],a[i]);
                        }
                        else
                        {
                            printf("%d+",a[j]);
                        }
                        sum -= a[j];
                    }
                }
            }
        }
    }
    else
    {
        for(int i=begin;i<n;i++)
        {
            if(sum+a[i]<=a[n-1])
            {
                sum += a[i];
                vis[i] = true;
                len--;
                dfs(i+1,len,sum);
                sum -= a[i];
                vis[i] = false;
                len++;
            }
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        flag = false;
        sort(a,a+n);    //对a进行排序
        memset(vis,false,sizeof(vis));  //初始化vis
        for(int i=2;i<n;i++)
        {
            dfs(0,i,0);
        }
        if(!flag)
        {
            printf("Can't find any equations!");
        }
        else
        {
            printf("\n");
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值