2015 Multi-University Training Contest 5 - MZL's simple problem

MZL's simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
A simple problem Problem Description You have a multiple set,and now there are three kinds of operations: 1 x : add number x to set 2 : delete the minimum number (if the set is empty now,then ignore it) 3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
  
  
The first line contains a number N ( N106 ),representing the number of operations. Next N line ,each line contains one or two numbers,describe one operation. The number in this set is not greater than 109 .
 

Output
  
  
For each operation 3,output a line representing the answer.
 

Sample Input
  
  
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
  
  
3 4
 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<set>
using namespace std;

int main()
{
    set<int>st;
    st.clear();
    int n,i,j,k,x,y;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&x);
        if(x==1){
            scanf("%d",&y);
            st.insert(y);
        }
    
        
    
        else if(x==2){
            if(!st.empty())
                st.erase(st.begin());
        }
        else if(x==3){
            if(st.empty())
			    printf("0\n");
            else {
                printf("%d\n",*--st.end());
            }
        }
    }
    
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值