hdu 1213 How Many Tables(并查集+路径压缩)

传送门

题目:

Problem Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

代码:

#include<bits/stdc++.h>
using namespace std;
const int N=1005;
int a[N],n,m;
void prepare(){
    for(int i=1;i<=n;i++){
        a[i]=i;
    }
}
int find(int x){
    while(x!=a[x]){
        x=a[a[x]];
    }
    return x;
}
void merge(int x,int y){
    x=find(x);
    y=find(y);
    if(x!=y){
        a[x]=y;
    }
}
map<int,int> mp;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        mp.clear();
        cin>>n>>m;
        prepare();
        while(m--){
            int x,y;
            cin>>x>>y;
            merge(x,y);
        }
        //for(int i=1;i<=n;i++) cout<<a[i]<<endl;
        int ans=0;
        for(int i=1;i<=n;i++){
            int f=find(a[i]);
            if(!mp[f]){
                mp[f]=1;
                ans++;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

原因分析:

提示:这里填写问题的分析:
例如:Handler 发送消息有两种方式,分别是 Handler.obtainMessage()和 Handler.sendMessage(),其中 obtainMessage 方式当数据量过大时,由于 MessageQuene 大小也有限,所以当 message 处理不及时时,会造成先传的数据被覆盖,进而导致数据丢失。


总结:

并查集代码模板:

void prepare(){
    for(int i=1;i<=n;i++){
        a[i]=i;
    }
}
int find(int x){
    while(x!=a[x]){
        x=a[a[x]];
    }
    return x;
}
void merge(int x,int y){
    x=find(x);
    y=find(y);
    if(x!=y){
        a[x]=y;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值