poj--1942

                                                                                                                    Paths on a Grid
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 23292 Accepted: 5739
Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:


Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.
Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input

5 4
1 1
0 0
Sample Output

126

2

题目考点:组合

题目来源:http://poj.org/problem?id=1942

解体思路:首先要注意的是,如果用C++写的,要用double型来接受参数,我就是这样一直WA.开始时我用的是递推,结果超时,于是我又换成二维数组,结果runingtime error.再换种方法,在网上找了一种最优的思路,m * n的方格,从左下方走到右上方共有m + n步,选取其中的m步为横向的,那么纵向的也就确定了,所以结果为m + n个中取出n或m个的所有组合数。这思维能力太强大了.

代码如下:

#include<stdio.h>
int main()
{
    double n,m,t,sum,d;
	while(scanf("%lf%lf",&n,&m))
	{
		if(n==0&&m==0)
		break;
		if(n>m)
		{
			t=n;
			n=m;
			m=t;
		}
		d=m+n;
		sum=1.0;
		while(n>0)
		{
			sum*=d/n;
			d--;
			n--;
		}
		printf("%.0lf\n",sum);
		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值