hdu--1709

                                                   The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6821    Accepted Submission(s): 2800


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1709
考察点:母函数
解题思路:这道题除了有一些变通需要想清楚,剩下就是套模板了.砝码可以放在天平两边,所以所给的重量不仅可以相加组合,还可以相减组合,但重物的数量只有一个.
代码如下:
#include<stdio.h>
#include<string.h>
#include<math.h>
int a[110];
int b[10100];
int c1[10100];
int c2[10100];
int main()
{
	int n,i,j,k,sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		c1[0]=1;c1[a[1]]=1;
		for(i=2;i<=n;i++)
		{
			for(j=0;j<=sum;j++)
			{
				for(k=0;k+j<=sum,k<=a[i];k+=a[i])
				{
				      c2[k+j]+=c1[j];
				      c2[abs(k-j)]+=c1[j];//砝码可以放两边 
				}
			}
			for(j=0;j<=sum;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
	    k=0;
		for(i=1;i<=sum;i++)
		{
			if(!c1[i])
			{
				b[k++]=i;
			}
		}
		if(k)
		{
			printf("%d\n",k);
			for(i=0;i<k-1;i++)
				printf("%d ",b[i]);
			printf("%d\n",b[i]);
		}
		else
		printf("0\n");
	}
	return 0;
}

法二:下面的方法是通过都加一个数,使得出现负数次方的情况也考虑了

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n,m;
int a[111];
int c1[22222],c2[22222];
const int cc=10001;

int main()
{
while(scanf("%d",&n)!=EOF)
{
    int m=0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        m+=a[i];
    }

    memset(c1,0,sizeof(c1));
    memset(c2,0,sizeof(c2));

    for(int i=-a[1];i<=a[1];i+=a[1])
    {
        c1[i+cc]=1;
    }

    for(int i=2;i<=n;i++)
    {
        for(int j=-m;j<=m;j++)
        {
            for(int k=-a[i];k+j<=m&&k<=a[i];k+=a[i])
            {
                c2[k+j+cc]+=c1[j+cc];
            }
        }
        for(int j=-m;j<=m;j++)
        {
            c1[j+cc]=c2[j+cc];
            c2[j+cc]=0;
        }
    }

    int aas[10000]={0};
    int ans=0;
    for(int i=0;i<=m;i++)
    {
        if(c1[i+cc]||c1[-i+cc]) ;
        else
        {
            aas[ans]=i;
            ans++;
        }
    }

    printf("%d\n",ans);
    for(int i=0;i<ans;i++)
    {
        if(i==0)
            printf("%d",aas[i]);
        else
            printf(" %d",aas[i]);
    }
    if(ans)
    putchar(10);

}

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值