poj--1426

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23212 Accepted: 9569 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
 
解题思路:题目的意思是找到n的非零倍数( nonzero multiple)m,并且m只有0,1组成,m不超过100位,m可能有多个,只要输出其中一个就可以了。简单的dfs。

代码如下:
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
int n,flag;
int a[110][2];
int b[2]={0,1};
int res[110];
void dfs(int ans,int id){
	if(flag)return ;
	if(id>100)return ;
	if(ans%n==0){
		flag=1;
		for(int i=1;i<=id;i++){
			printf("%d",res[i]);
		}
		printf("\n");
		return ;
	}
	for(int i=0;i<2;i++){
        if(!a[id+1][b[i]]){
        	a[id+1][b[i]]=1;
        	res[id+1]=b[i];
        	int m=(ans*10+b[i])%n;
        	dfs(m,id+1);
        	a[id+1][b[i]]=0;
        }
	}
}
int main(){
	while(scanf("%d",&n)&&n){
	    if(n==1){
	    printf("1\n");
	    continue;
	    }
	    flag=0;
	    res[1]=1;
		memset(a,0,sizeof(a));
		a[1][1]=1;
	    dfs(1,1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值