Description
给你一个n个数的数列,其中某个数出现了超过n div 2次即众数,请你找出那个数。
Input
第1行一个正整数n。
第2行n个正整数用空格隔开。
Output
一行一个正整数表示那个众数。
Sample Input
5 3 2 3 1 3
Sample Output
3
Hint
100%的数据,n<=500000,数列中每个数<=maxlongint。
解体思路:这题思维方法好巧妙,一开始我是想从小到大快速排序,取处数组中间的数就是所求的数,这比顺序判断快多了,
然而还是超时了,开了解题报告,人家用的思维方式好灵活,值得收藏.
代码如下:
#include<stdio.h>
int main(){
int n,toal,i;
long long a,now;
while(scanf("%d",&n)!=EOF){
toal=0;now=0;
for(i=1;i<=n;i++){
scanf("%lld",&a);
if(a==now){
toal++;
}
else{
toal--;
}
if(toal<0){
now=a;
toal=0;
}
}
printf("%lld\n",now);
}
}