杭电 OJ 1302 The Snail

The Snail

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2954    Accepted Submission(s): 2129


Problem Description
A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day. 

Day| Initial Height| Distance Climbed |Height After Climbing |Height After Sliding 
1 0 3 3 2 
2 2 2.7 4.7 3.7 
3 3.7 2.4 6.1 - 

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.
 

Input
The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.
 

Output
For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.
 

Sample Input
  
  
6 3 1 10 10 2 1 50 50 5 3 14 50 6 4 1 50 6 3 1 1 1 1 1 0 0 0 0
 

Sample Output
  
  
success on day 3 failure on day 4 failure on day 7 failure on day 68 success on day 20 failure on day 2

#include <iostream>

using namespace std;

int main()

{

    double h,u,d,f;

    while(cin>>h>>u>>d>>f&&h)//6总共需要爬行的高度 3//上升 1//下降 10 //10这一行代表疲劳百分比的分子

    {

        double s=u*f/100,sum=0;

        int day=0;

        int a=1;

        while(1)

        {

            day++;

            sum+=u;

            if(sum>h)   //根据题目所给例子可知,只有在蜗牛爬行总高度超过预定高度时,蜗牛才算爬出来

                break;

            sum-=d;

            if(sum<0)   

            {

                a=0;

                break;

            }

            u-=s;

            if(u<0)     //太疲劳了,不能再上升了,肯定不能爬出去。

                u=0;

        }

        if(a)

            cout<<"success on day "<<day<<endl;

        else

            cout <<"failure on day "<<day<<endl;

    }

    return 0;

}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值