【二分】Base Station Sites @ICPC2017HongKong/upcexam5559

时间限制: 1 Sec 内存限制: 128 MB

5G is the proposed next telecommunications standards beyond the current 4G standards. 5G planning aims at higher capacity than current 4G, allowing a higher density of mobile broadband users, and supporting device-to- device, reliable, and massive wireless communications. A telecommunication company would like to install more base stations to provide better communication for customers. Due to the installation cost and available locations,the company can only install S (2 ≤ S ≤ L) base stations at L (2 ≤ L ≤ 100, 000) candidate locations. Since the base stations work in the same frequency band, they will interfere and cause severe performance degradation. To provide high quality communication experience to customers, the company would like to maximize the distance between the base stations so as to reduce the wireless interference among the base stations. Suppose the L candidate locations are in a straight line at locations P1, P2,…, PL (0 ≤ Pi ≤ 1, 000, 000) and the company wants to install S base stations at the L candidate locations. What is the largest minimum distance among the S base stations?

The input data includes multiple test sets.
Each set starts with a line which specifies L (i.e., the number of candidate locations) and S (i.e., the number of base stations). The next line contains L space-separated integers which represent P1, P2,…, PL.
The input data ends “0 0”.
For each set, you need to output a single line which should be the largest minimum distance among the base stations.

sample input
5 3
2 3 9 6 11
4 3
1 4 9 10
0 0

sample output
4

给你L个点,要你选S个点,要求这些点之间的最小距离最大,输出这个最大值
二分答案

#define IN_PC() freopen("C:\\Users\\hz\\Desktop\\in.txt","r",stdin)
#define OUT_PC() freopen("C:\\Users\\hz\\Desktop\\out.txt","w",stdout)
#include <bits/stdc++.h>

using namespace std;

const int maxn = 100005;
int L,S,P[maxn];

bool judge(int _val) {
    int ret = 1;
    int las = P[0];
    for(int i = 1; i<L; i++) {
        if(P[i]-las>=_val) {
            ret++;
            las = P[i];
        }
    }
    return ret>=S;
}

int main() {
//    IN_PC();
//    OUT_PC();
    while(scanf("%d%d",&L,&S)&&!(L==0&&S==0)) {
        for(int i=0; i<L; i++) {
            scanf("%d",P+i);
        }
        sort(P,P+L);
        int l = 0,r = 1000005;
        while(l<r) {
            int mid = ((l+r)%2)?((l+r)/2+1):((l+r)/2);
            if(judge(mid))
                l = mid;
            else
                r = mid-1;
        }
        printf("%d\n",(l+r)/2);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值