HDU-balloons-求颜色最多的气球的颜色

79 篇文章 0 订阅
问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月19日  
*版 本 号:v1.0  
*  
*问题描述:Contest time again! How excited it is to see balloons floating around. But to 

tell you a secret, the judges' favorite time is guessing the most popular problem. When the 

contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
*程序输入:Input contains multiple test cases. Each test case starts with a number N (0 < N 

<= 1000) -- the total number of balloons distributed. The next N lines contain one color 

each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
*程序输出:For each case, print the color of balloon for the most popular problem on a 

single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

*/
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main()
{
    char a[1001][16];
    int t;
    int n,i,j,max,flag;
    while(cin>>n&&n!=0)
    {
        getchar();
        for(i=0; i<n; i++)
        {
            gets(a[i]);
        }
        max=1;
        flag=0;
        for(i=0; i<n; i++)
        {
            t=1;
            if(a[i][0]=='\0') continue;
            for(j=i+1; j<n; j++)
            {
                if(a[j][0]=='\0') continue;
                if(strcmp(a[i],a[j])==0)
                {
                    t++;
                    a[j][0]='\0';
                }
            }
            if(t>max)
            {
                max=t;
                flag=i;
            }
        }
        puts(a[flag]);
    }
    return 0;
}



运行结果:




知识点总结:
求颜色最多的气球的颜色。

学习心得:

二维数组。。。这就能用上了。。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值