HDU-多个大数加法问题

问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
*程序输入:The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.
*程序输出:Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input
1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670
*/
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    char str[100];
    int x,c,n,i,j,sum[110];
    cin>>n;
    while(n--)
    {
        memset(sum,0,sizeof(sum));
        c=0;
        while(cin>>str,strcmp(str,"0"))
        {
            for(i=j=strlen(str)-1; 0<=i; i--)
                sum[j-i]+=str[i]-'0';
        }
        for(i=0; i<110; i++)
        {
            x=sum[i]+c;
            sum[i]=x%10;
            c=x/10;
        }
        i=109;
        while(sum[i]==0)i--;
        if(i<0)cout<<"0";
        for(; i>=0; i--)
            cout<<sum[i];
        cout<<endl;
        if(n)cout<<endl;
    }
    return 0;
}



运行结果:


知识点总结:
多个大数加法问题。

学习心得:

跟小数加法差不多。。

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值