POJ 1562-Oil Deposits-油田搜索

138 篇文章 0 订阅
29 篇文章 0 订阅
问题及代码:

Problem C Oil Deposits


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 3
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2


/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.    
*文件名称:HDU.cpp    
*作    者:单昕昕    
*完成日期:2015年2月27日    
*版 本 号:v1.0        
*/ 
#include <iostream>
#include <cstring>
using namespace std;
const int MAX=100;
int m,n;
char map[MAX][MAX];
bool flag[MAX][MAX];
int move_x[8]={-1,0,1,1,1,0,-1,-1};
int move_y[8]={-1,-1,-1,0,1,1,1,0};
void dfs(int x,int y)
{
    int i;
    if (map[x][y]=='@'&&flag[x][y]==false)
    {
        flag[x][y]=true;
        for(i=0; i<8; i++)
        {
            int tx=x+move_x[i];
            int ty=y+move_y[i];
            if (tx>=0&&ty>=0&&tx<m&&ty<n&&map[tx][ty]=='@'&&flag[tx][ty]==false)
            {
                dfs(tx,ty);
            }
        }
        return ;
    }
}
int main()
{
    while(cin>>m>>n&&m!=0&&n!=0)
    {
        memset(flag,false,sizeof(flag));
        int i,j,sum=0;
        for(i=0; i<m; i++)
            for(j=0; j<n; j++)
                cin >> map[i][j];
        for(i=0; i<m; i++)
            for(j=0; j<n; j++)
            {
                if(map[i][j]=='@'&&flag[i][j]==false)
                {
                    dfs(i,j);
                    sum++;
                }
            }
        cout<<sum<<endl;
    }
    return 0;
}


运行结果:



知识点总结:
递归搜索。

学习心得:

主要是得注意连在一起的油田是指周围八块,用递归好做点。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值