POJ 3122/HDU 1969-Pie-二分法分馅饼

138 篇文章 0 订阅
79 篇文章 0 订阅
问题及代码:

 Pie

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655


/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.    
*文件名称:HDU.cpp    
*作    者:单昕昕    
*完成日期:2015年3月2日    
*版 本 号:v1.0        
*/ 
#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;
const double eps=1e-8;
const double PI=acos(-1.0);
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,f,i,sum;
        double s[10000],min=0.0,max=0.0,mid;
        cin>>n>>f;
        f++;
        for(i=0; i<n; i++)
        {
            cin>>s[i];
            s[i]*=s[i];
            if(s[i]>max)
                max=s[i];
        }
        while(max-min>eps)
        {
            mid=(max+min)/2;
            sum=0;
            for(i=0; i<n; i++)
                sum+=s[i]/mid;
            if(sum<f)
                max=mid;
            else min=mid;
        }
        printf("%.4lf\n",PI*mid);
    }
    return 0;
}


运行结果:



知识点总结:
二分法。

学习心得:

先找出上下界,下界为0,上界是n个pie中尺寸最大的那个,即每个人得到整个pie,而且是最大的那个。
不断二分,若求出的人数大于f+1,说明现在分得的pie小了,更改min值,否则,更改max值。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值