Problem D: C++习题 对象数组输入与输出
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 1189 Solved: 847
[ Submit][ Status][ Web Board]
Description
建立一个对象数组,内放n(n<10)个学生的数据(学号、成绩),用指针指向数组首元素,输出第奇数(1,3,5,7)个学生的数据。
Input
n和n个学生的学号、成绩
Output
奇数学生的数据
Sample Input
5
101 78.5
102 85.5
103 98.5
104 100.0
105 95.5
Sample Output
101 78.50
103 98.50
105 95.50
HINT
主函数已给定如下,提交时不需要包含下述主函数
/* C++代码 */
int main()
{
const int NUM=10;
Student stud[NUM];
int n,i;
cin>>n;
for(i=0; i<n; i++)
stud[i].input();
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
Student *p=stud;
for(i=0; i<n; p+=2,i+=2)
p->display();
return 0;
}
<span style="font-size:14px;">/*
*Copyright (c)2015,烟台大学计算机与控制工程学院
*All rights reserved.
*作 者:单昕昕
*完成日期:2015年5月16日
*版 本 号:v1.0
*/
#include <iostream>
#include <iomanip>
using namespace std;
class Student
{
public:
Student(int n=0,double s=0):num(n),score(s) {}
void input();
void display();
private:
int num; //学号
double score; //成绩
};
void Student::input()
{
double n,s;
cin>>n>>s;
num=n;
score=s;
}
void Student::display()
{
cout<<num<<" "<<score<<endl;
}
int main()
{
const int NUM=10;
Student stud[NUM];
int n,i;
cin>>n;
for(i=0; i<n; i++)
stud[i].input();
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
Student *p=stud;
for(i=0; i<n; p+=2,i+=2)
p->display();
return 0;
}
</span>