YTU-OJ- 对象数组求最大值

Problem E: C++习题 对象数组求最大值

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 1013   Solved: 735
[ Submit][ Status][ Web Board]

Description

建立一个对象数组,内放n(<10)个学生的数据(学号、成绩),设立一个函数max,用指向对象的指针作函数参数,在max函数中找出n个学生中成绩最高者,并输出其学号。

Input

n和n个学生的学号、成绩

Output

成绩最高者的学号和成绩

Sample Input

5
101 78.5
102 85.5
103 98.5
104 100.0
105 95.5

Sample Output

104 100.00

HINT


主函数已给定如下,提交时不需要包含下述主函数



/* C++代码 */



int main()

{

    void max(Student* ,int);

    const int NUM=10;

    Student stud[NUM];

    int n,i;

    cin>>n;

    for(i=0; i<n; i++)

        stud[i].input();

    cout<<setiosflags(ios::fixed);

    cout<<setprecision(2);

    Student *p=&stud[0];

    max(p,n);

    return 0;

}


<span style="font-size:14px;">/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.      
*作    者:单昕昕    
*完成日期:2015年5月16日    
*版 本 号:v1.0        
*/ 
#include <iostream>
#include <iomanip>
using namespace std;
class Student
{
public:
    Student(int n=0,double s=0):num(n),score(s) {}
    int get_num();
    void input();
    double get_score();
    void display();

private:
    int num;   //学号
    double score;   //成绩
};

int Student::get_num()
{
    return num;
}
double Student::get_score()
{
    return score;
}
void max(Student *arr,int n)
{
    double max=arr[0].get_score();
    int i,no;
    for(i=0; i<n; ++i)
    {
        if(arr[i].get_score()>max)
            no=i;
    }
    no--;
    arr[no].display();
}
void Student::input()
{
    double n,s;
    cin>>n>>s;
    num=n;
    score=s;
}
void Student::display()
{
    cout<<num<<" "<<score<<endl;
}

int main()

{
    void max(Student* ,int);
    const int NUM=10;
    Student stud[NUM];
    int n,i;
    cin>>n;
    for(i=0; i<n; i++)
        stud[i].input();
    cout<<setiosflags(ios::fixed);
    cout<<setprecision(2);
    Student *p=&stud[0];
    max(p,n);
    return 0;
}</span><span style="font-size: 24px;">
</span>


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值