YT02-简单数学课堂题-1003 The area -(5.31日-烟台大学ACM预备队解题报告)

79 篇文章 0 订阅

The area

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 45   Accepted Submission(s) : 39
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.


Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output

For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

Sample Output

33.33
40.69

Hint

For float may be not accurate enough, please use double instead of float.

Author

Ignatius.L


145- 刘畅


这道题目的主要思路就是先根据已知三点坐标来求一元二次方程 y=a*x^2+b* x+c

8 p=y1/((x1-x2)*(x1-x3));
8 q=y2/((x2-x1)*(x2-x3));
8 r=y3/((x3-x1)*(x3-x2));
8 a= p+q+r ;
8 b=-p*(x2+x3)-q*(x1+x3)-r*(x1+x2);
8 c=p*x2*x3+q*x1*x3+r*x1*x2;
8  
8 然后有 P2 P3 两点求得直线的方程 y= kx+b ;
8 k=(y3-y2)/(x3-x2);
8 \d=y2-k*x2;
8 求积分即可得到面积
      #include <iostream>
#include <iomanip>
using namespace std;
int main()
{
    double x1,x2,y1,y2,x3,y3,a,b,c,p,q,r,k,d,s;
    int T;
    cin>>T;
    while (T--)
    {
cin>>x1>>y1;
        cin>>x2>>y2;
        cin>>x3>>y3;
        p=y1/((x1-x2)*(x1-x3));
        q=y2/((x2-x1)*(x2-x3));
        r=y3/((x3-x1)*(x3-x2));
        a=p+q+r;
        b=-p*(x2+x3)-q*(x1+x3)-r*(x1+x2);
        c=p*x2*x3+q*x1*x3+r*x1*x2;
        k=(y3-y2)/(x3-x2);
        d=y2-k*x2;
        s=1.0/3.0*a*(x3*x3*x3-x2*x2*x2)+0.5*(b-k)*(x3*x3-x2*x2)+(c-d)*(x3-x2);
cout<<setiosflags(ios::fixed)<<setprecision(2)<<s<<endl;
    }
    return 0;
}<span style="font-family:微软雅黑;"><strong style="font-size: 26pt; line-height: 1.4em;">
</strong></span>




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值